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WHERE ARE THE LESSON FILES?
Purchase of this Classroom in a Book in any format gives you access to the lesson 
�les you’ll need to complete the exercises in the book.

1 Go to peachpit.com/AfterE�ectsCIB2024.

2 Sign in or create a new account.

3 Click Submit.

•Note: If you encounter problems registering your product or accessing the lesson files or web 
edition, go to peachpit.com/support for assistance.

4 Answer the questions as proof of purchase.

5 �e lesson �les can be accessed through the Registered Products tab on your 
Account page.

6 Click the Access Bonus Content link below the title of your product to proceed 
to the download page. Click the lesson �le links to download them to your 
computer.

•Note: If you purchased a digital product directly from peachpit.com, your product will already be 
registered. Look for the Access Bonus Content link on the Registered Products tab in your account. 

http://peachpit.com/AfterE$$$�ectsCIB2024
http://peachpit.com/support
http://peachpit.com


CONTENTS

iv CONTENTS

WHERE ARE THE LESSON FILES? iii

GETTING STARTED 1

About Classroom in a Book . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1

Prerequisites . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2

Installing After Effects, Bridge, and Media Encoder . . . . . . . . . . . 2

Activating fonts . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2

Optimizing performance . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3

Restoring default preferences . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3

Online content  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4

How to use these lessons  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6

Additional resources . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6

Adobe Authorized Training Centers . . . . . . . . . . . . . . . . . . . . . . . . . . 7

1 GETTING TO KNOW THE WORKFLOW 8

About the After Effects work area . . . . . . . . . . . . . . . . . . . . . . . . . . . 10

Getting started . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11

Creating a project and importing footage  . . . . . . . . . . . . . . . . . . 11

Creating a composition and arranging layers  . . . . . . . . . . . . . . . 15

About layers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17

Adding effects and modifying layer properties . . . . . . . . . . . . . . 18

Animating the composition . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22

About the Tools panel . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24

About timecode and duration . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 26

About the Timeline panel . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27

Previewing your work . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30

Using the Properties panel . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30

Optimizing performance in After Effects . . . . . . . . . . . . . . . . . . . . 33

Rendering and exporting your composition  . . . . . . . . . . . . . . . . 33

Customizing workspaces . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33

Controlling the brightness of the user interface  . . . . . . . . . . . . 35

Collaborating in After Effects . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 36

Finding resources for using After Effects . . . . . . . . . . . . . . . . . . . . 36

Review questions and answers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 37



ADOBE AFTER EFFECTS CLASSROOM IN A BOOK 2024 RELEASE v

2 CREATING A BASIC ANIMATION USING EFFECTS AND PRESETS 38

Getting started . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 40

Creating a new composition  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 40

Working with imported Illustrator layers . . . . . . . . . . . . . . . . . . . . 43

Applying effects to a layer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 46

Applying and controlling effects  . . . . . . . . . . . . . . . . . . . . . . . . . . . 47

Applying an animation preset . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 48

Precomposing layers for a new animation  . . . . . . . . . . . . . . . . . . 49

Previewing the effects  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 50

Adding transparency  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51

Rendering the composition . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 52

Review questions and answers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 55

3 ANIMATING TEXT 56

Getting started . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 58

About text layers  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 60

Installing a font using Adobe Fonts . . . . . . . . . . . . . . . . . . . . . . . . . 60

Creating and formatting point text . . . . . . . . . . . . . . . . . . . . . . . . . 63

Animating with scale keyframes . . . . . . . . . . . . . . . . . . . . . . . . . . . . 65

Using a text animation preset . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 67

About Adobe Bridge . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 69

Animating imported Photoshop text . . . . . . . . . . . . . . . . . . . . . . . 71

Animating type tracking . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 75

Animating text opacity . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 77

Animating an image to replace text  . . . . . . . . . . . . . . . . . . . . . . . . 77

Using a text animator group  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 80

About text animator groups . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81

Animating a layer’s position . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 83

Adding motion blur . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 85

Review questions and answers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 87

4 WORKING WITH SHAPE LAYERS 88

Getting started . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 90

Creating the composition . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 90

Adding a shape layer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 91

Creating a self-animating shape . . . . . . . . . . . . . . . . . . . . . . . . . . . . 93

Duplicating a shape . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 95



Creating custom shapes with the Pen tool . . . . . . . . . . . . . . . . . . 98

Positioning layers with snapping . . . . . . . . . . . . . . . . . . . . . . . . . . 100

Animating a shape . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 102

Animating using parenting . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 106

Using nulls to connect points  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 110

About parent and child layers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 110

Previewing the composition  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 113

Animating layers to match audio  . . . . . . . . . . . . . . . . . . . . . . . . . . 114

Review questions and answers . . . . . . . . . . . . . . . . . . . . . . . . . . . . 115

5 ANIMATING A MULTIMEDIA PRESENTATION 116

Getting started . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 118

Using Creative Cloud Libraries in After Effects . . . . . . . . . . . . . . 119

Adjusting anchor points  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 121

Parenting layers  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 123

Precomposing layers  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 125

Keyframing a motion path  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 127

Animating additional elements . . . . . . . . . . . . . . . . . . . . . . . . . . . . 131

Applying an effect . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 135

About solid-color layers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 136

Animating precomposed layers  . . . . . . . . . . . . . . . . . . . . . . . . . . . 139

Animating the background  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 141

Supported audio file formats . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 142

Adding an audio track  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 143

Editing audio files in Adobe Audition . . . . . . . . . . . . . . . . . . . . . . 144

Review questions and answers . . . . . . . . . . . . . . . . . . . . . . . . . . . . 145

6 ANIMATING LAYERS 146

Getting started . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 148

Preparing layered Photoshop files . . . . . . . . . . . . . . . . . . . . . . . . . 150

Simulating lighting changes  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 151

Duplicating an animation using the pick whip . . . . . . . . . . . . . 153

About Photoshop layer styles  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 155

Using a track matte to confine animation . . . . . . . . . . . . . . . . . . 156

About expressions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 156

About track mattes and traveling mattes  . . . . . . . . . . . . . . . . . . 159

vi CONTENTS



ADOBE AFTER EFFECTS CLASSROOM IN A BOOK 2024 RELEASE vii

Animating using the Corner Pin effect . . . . . . . . . . . . . . . . . . . . . 161

Simulating a darkening sky . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 163

Viewing render times for layers . . . . . . . . . . . . . . . . . . . . . . . . . . . . 167

Retiming the composition  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 168

Review questions and answers . . . . . . . . . . . . . . . . . . . . . . . . . . . . 179

7 WORKING WITH MASKS 180

About masks  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 182

Getting started . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 182

Creating a mask with the Pen tool . . . . . . . . . . . . . . . . . . . . . . . . . 184

Tips for creating masks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 184

Editing a mask . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 185

About mask modes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 185

Feathering the edges of a mask  . . . . . . . . . . . . . . . . . . . . . . . . . . . 188

Replacing the content of the mask  . . . . . . . . . . . . . . . . . . . . . . . . 188

Creating a Bezier mask . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 188

Zooming and panning by touch . . . . . . . . . . . . . . . . . . . . . . . . . . . 189

Adjusting the opacity . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 191

Adding a shadow . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 191

Creating a vignette  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 196

Using the Rectangle and Ellipse tools . . . . . . . . . . . . . . . . . . . . . . 197

Review questions and answers . . . . . . . . . . . . . . . . . . . . . . . . . . . . 199

8 DISTORTING OBJECTS WITH THE PUPPET TOOLS 200

Getting started . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 202

About the Puppet tools . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 207

Adding Position pins . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 208

Adding Advanced and Bend pins . . . . . . . . . . . . . . . . . . . . . . . . . . 210

Defining areas of overlap . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 212

Stiffening an area . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 213

Squash and stretch  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 213

Animating pin positions. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 214

Using the Puppet tools to animate video  . . . . . . . . . . . . . . . . . . 215

Recording animation. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 216

Extra credit  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 218

Review questions and answers . . . . . . . . . . . . . . . . . . . . . . . . . . . . 219



9 USING THE ROTO BRUSH TOOL 220

About rotoscoping . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 222

Getting started . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 222

Creating a segmentation boundary . . . . . . . . . . . . . . . . . . . . . . . . 224

Editing Adobe Premiere Pro clips with After Effects  . . . . . . . . 227

Fine-tuning the matte  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 231

Refine Soft Matte and Refine Hard Matte effects  . . . . . . . . . . . 232

Freezing your Roto Brush tool results . . . . . . . . . . . . . . . . . . . . . . 234

Changing the background . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 235

Adding animated text . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 238

Outputting your project. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 241

Extra credit . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 243

Review questions and answers . . . . . . . . . . . . . . . . . . . . . . . . . . . . 245

10 ADJUSTING COLOR AND MOOD 246

Getting started . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 248

Previewing your project on a video monitor  . . . . . . . . . . . . . . . 250

Detecting scenes in a composition . . . . . . . . . . . . . . . . . . . . . . . . 251

Making color enhancements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 252

Adding a colorized effect . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 255

Replacing a background . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 257

Color-correcting using Auto Contrast . . . . . . . . . . . . . . . . . . . . . . 261

Cloning an object in a scene  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 261

Darkening a scene . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 265

Freezing the action  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 270

Adding transitions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 274

Review questions and answers . . . . . . . . . . . . . . . . . . . . . . . . . . . . 277

11 CREATING MOTION GRAPHICS TEMPLATES 278

Getting started . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 280

Preparing a master composition . . . . . . . . . . . . . . . . . . . . . . . . . . . 281

Setting up a template . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 286

Adding properties to the Essential Graphics panel  . . . . . . . . . 287

Protecting the timing of a section . . . . . . . . . . . . . . . . . . . . . . . . . 291

Exporting the template . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 292

Creating essential properties . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 294

Extra credit  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 295

Review questions and answers . . . . . . . . . . . . . . . . . . . . . . . . . . . . 297

viii CONTENTS



ADOBE AFTER EFFECTS CLASSROOM IN A BOOK 2024 RELEASE ix

12 USING 3D FEATURES 298

Getting started . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 300

Creating a 3D shape in After Effects. . . . . . . . . . . . . . . . . . . . . . . . 301

Viewing the 3D ground plane . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 303

Using the 3D Transform Gizmo . . . . . . . . . . . . . . . . . . . . . . . . . . . . 304

Importing 3D objects . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 305

About importing 3D objects  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 306

Creating 3D text . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 307

Converting 2D objects to 3D . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 308

Using 3D views . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 309

Using the camera tools . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 310

Adding a background . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 312

Lighting a scene . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 312

Adding a camera. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 316

Using HDR images as lights  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 316

Animating objects in a 3D scene  . . . . . . . . . . . . . . . . . . . . . . . . . . 318

Animating a camera  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 320

3D channel effects . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 321

Working with Cinema 4D Lite  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 322

Review questions and answers . . . . . . . . . . . . . . . . . . . . . . . . . . . . 323

13 WORKING WITH THE 3D CAMERA TRACKER 324

About the 3D Camera Tracker effect . . . . . . . . . . . . . . . . . . . . . . . 326

Getting started . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 326

Tracking the footage . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 328

Repairing rolling shutter distortions . . . . . . . . . . . . . . . . . . . . . . . 328

Creating a ground plane, a camera, and the initial text . . . . . 329

Creating additional text elements . . . . . . . . . . . . . . . . . . . . . . . . . 333

Locking an image to a plane with a solid layer  . . . . . . . . . . . . . 336

Adjusting the camera’s depth of field . . . . . . . . . . . . . . . . . . . . . . 337

Tidying the composition . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 339

Adding a final object . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 340

Creating realistic shadows. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 341

Adding ambient light . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 343

Adding an effect . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 343

Previewing the composition  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 344

Review questions and answers . . . . . . . . . . . . . . . . . . . . . . . . . . . . 345



14 ADVANCED EDITING TECHNIQUES 346

Getting started . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 348

Stabilizing a shot  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 348

Bicubic scaling . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 349

Warp Stabilizer VFX settings . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 351

Removing motion blur . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 353

Using single-point motion tracking . . . . . . . . . . . . . . . . . . . . . . . . 356

Moving and resizing the track points . . . . . . . . . . . . . . . . . . . . . . 359

Removing unwanted objects . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 363

Checking for drift . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 363

Creating a particle simulation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 367

Mocha AE  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 367

Understanding Particle Systems II properties  . . . . . . . . . . . . . . 370

About high dynamic range (HDR) footage . . . . . . . . . . . . . . . . . 378

Retiming playback using the Timewarp effect . . . . . . . . . . . . . . 379

Review questions and answers . . . . . . . . . . . . . . . . . . . . . . . . . . . . 385

15 RENDERING AND OUTPUTTING 386

Getting started . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 388

About rendering and output . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 389

Exporting using the Render Queue . . . . . . . . . . . . . . . . . . . . . . . . 389

Preparing movies for mobile devices  . . . . . . . . . . . . . . . . . . . . . . 392

Creating templates for the Render Queue. . . . . . . . . . . . . . . . . . 393

Rendering movies with Adobe Media Encoder . . . . . . . . . . . . . 394

About compression . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 395

Preparing a movie for broadcast output  . . . . . . . . . . . . . . . . . . . 400

Review questions and answers . . . . . . . . . . . . . . . . . . . . . . . . . . . . 401

APPENDIX: TOOLS FOR TROUBLESHOOTING 402

INDEX 403

x CONTENTS



220

USING THE ROTO BRUSH TOOL

Lesson overview
In this lesson, you’ll learn how to do the following:

• Extract a foreground object from the background using the 
Roto Brush tool.

• Correct the segmentation boundary across a span of frames.

• Touch up a matte with the Re�ne Edge tool. 

• Freeze a matte across a clip.

• Replace a background.

• Animate properties for creative e�ects.

• Track a face in footage.

�is lesson will take about an hour to complete. If you haven’t already 
done so, download the project �les for this lesson from peachpit.com/
AfterE�ectsCIB2024, following the instructions in the Getting Started 
section under “Accessing the lesson �les and Web Edition.” 

9

http://peachpit.com/AfterE�ectsCIB2024
http://peachpit.com/AfterE�ectsCIB2024
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With the Roto Brush tool, you can quickly separate 
a foreground object from a background across many 
frames. You can achieve professional results in a frac-
tion of the time you’d spend performing the same 
task with traditional rotoscoping.

PROJECT:  WEB BANNER PROJECT:  WEB BANNER 
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About rotoscoping
When you draw or paint on the frames of a movie, you’re rotoscoping. For example, a 
common use of rotoscoping is to trace an object, using the path as a mask to isolate 
it from the background so you can work with it separately. You could draw masks, ani-
mate the mask paths, and then use the masks to de�ne a matte. (A matte is a mask 
used to hide part of an image so that another image can be superimposed.) While 
e�ective, this is a time-intensive, tedious process, especially if the object moves a 
great deal or the background is complex.

If a background or foreground object is a consistent, distinct color, you could use 
color keying to separate the object from the background. If the subject was shot 
against a green or blue background (green screen or blue screen), keying is usually 
much easier than rotoscoping. However, keying is less e�cient when you’re work-
ing with complex backgrounds.

�e Roto Brush tool in After E�ects, powered by an AI model, is much faster than 
conventional rotoscoping. You use the Roto Brush tool to de�ne the foreground 
and background elements. �en After E�ects creates a matte, and tracks the move-
ment of the matte over time. �e Roto Brush tool does much of the work for you, 
leaving only a little cleanup work to be done. 

Getting started
In this lesson, you’ll use the Roto Brush tool to isolate a bird and rock pool so you can 
replace the background. To �nish up the project, you’ll add an animated title. 

First, you’ll preview the �nal movie and set up your project.

1 Make sure the following �les are in the Lessons/Lesson09 folder on your hard 
disk, or download them from peachpit.com now:

• In the Assets folder: Chickadee.mov, Facetracking.mov, MillPond.mov

• In the Sample_Movie folder: Lesson09.mp4

2 Open and play the Lesson09.mp4 sample movie in Windows Movies & TV 
or QuickTime Player to see what you will create in this lesson. When you are 
done, close Windows Movies & TV or QuickTime Player. You may delete the 
sample movie from your hard disk if you have limited storage space.

When you begin this lesson, restore the default application settings for After E�ects. 
See “Restoring default preferences” on page 3.

3 Start After E�ects, and then immediately hold down Ctrl+Alt+Shift (Windows) 
or Command+Option+Shift (macOS). In the Startup Repair Options dialog box, 
click Reset Preferences. 

http://peachpit.com
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4 Click New Project in the Home window.

After E�ects opens to display an empty, untitled project.

5 Choose File > Save As > Save As.

6 In the Save As dialog box, navigate to the Lessons/Lesson09/
Finished_Project folder.

7 Name the project Lesson09_Finished.aep, and then click Save.

Creating the composition
You’ll import a footage �le and create a composition from it.

1 Click New Composition From Footage in the Composition panel.

2 Navigate to the Lessons/Lesson09/Assets folder, select the Chickadee.mov �le, and 
then click Import or Open.

After E�ects creates a composition 
named Chickadee, based on the settings 
in the Chickadee.mov �le. �e composi-
tion is two and one half seconds long, 
with a frame size of 1920 x 1080. �e 
movie �le was shot at a rate of 29.97 
frames per second. 

3 Choose File > Save to save the project 
so far.
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Creating a segmentation boundary
You use the Roto Brush tool to specify which parts of the clip are in the foreground 
and which are in the background. You add strokes to distinguish the two, and then After 
E�ects creates a segmentation boundary between the foreground and background.

Creating a base frame
To use the Roto Brush tool to isolate a foreground object, you start by adding strokes 
to a base frame to identify foreground and background areas. You can start on any 
frame in the clip, but in this exercise, you’ll use the �rst frame as the base frame. 
First, you’ll add the strokes that identify the bird and the rock pool as the fore-
ground objects.

1 Move the current-time indicator across the time ruler to preview the footage. 

2 Press the Home key to move the current-time indicator to the beginning 
of the time ruler.

3 Select the Roto Brush tool ( ) in the Tools panel.

You use the Roto Brush tool in the Layer panel, which you’ll open now.

4 Double-click the Chickadee.mov layer in the Timeline panel to open the clip in the 
Layer panel.
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5 Choose Fit from the Magni�cation Ratio pop-up menu at the bottom of the Layer 
panel if you don’t see the entire image clearly.

By default, the Roto Brush tool creates green foreground strokes. You’ll start by adding 
strokes to the foreground—the rock pool and the bird. Generally, it’s most e�cient 
to start with broad strokes and then use smaller brushes to re�ne the border.

6 Choose Window > Brushes to open the Brushes panel. Set up a hard round 
100-pixel brush. (You may need to resize the Brushes panel to see the options.)

When you’re drawing strokes to de�ne the foreground object, follow the skeletal 
structure of the subject. Unlike traditional rotoscoping, you don’t need to de�ne a 
precise boundary around the object. Start with broad strokes, and work down to small 
regions as After E�ects determines where the boundary is supposed to be.

7 Draw a green stroke horizontally across the rock pool.

Roto Brush tool properties appear in the E�ect Controls panel. In the Layer panel, 
a magenta outline identi�es the boundaries After E�ects created for the foreground 
object. After E�ects recognized only about half of the pool, because you initially 
sampled only a small area of the subject. You’ll help After E�ects �nd the boundary 
by adding some more foreground strokes. First, you’ll make sure you’re using ver-
sion 3 of the Roto Brush tool. 

▶Tip: You can quickly 
zoom in and out of 
the Layer panel using 
the scroll wheel on your 
mouse, if it has one.
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8 In the E�ect Controls panel, make sure 3.0 is selected for the Version.

9 Still using a large brush, continue to draw green strokes along the inside edges of 
the pool. Do not include the branches directly behind the pool and the bird.

10 Zoom to 200% and use the Hand tool ( ) to pan to the bird.

11 Select the Roto Brush tool again. �en select a smaller brush, and draw a green 
stroke across the bird’s body.

It can be tricky to get some areas without accidentally adding background as well. 
It’s okay if you haven’t captured every detail in the foreground. You’ll use back-
ground strokes to remove any extraneous areas of the matte.

12 Press Alt (Windows) or Option 
(macOS) to switch to the red 
background stroke brush. Add red 
strokes to background areas you 
want to exclude from the matte. 
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13 Switch back and forth between the foreground and background brushes and brush 
sizes to �ne-tune the matte. Don’t forget to deselect the branches directly behind 
the bird and the pool. In some cases, one click may be all it takes to exclude an 
object or area from the matte. 

14 When you’re happy with the bird’s matte, zoom back out and �ne-tune any 
remaining areas that need to be addressed with the rock pool.

Editing Adobe Premiere Pro 
clips with After E�ects
You can work with a clip in both Adobe Premiere Pro and After Effects, moving 
easily between the two applications as you edit your project. 

To edit an Adobe Premiere Pro clip in After Effects, do the following:

1 Right-click or Control-click the clip in Adobe Premiere Pro, and choose Replace 
With After Effects Composition. 

After Effects starts, and opens the Adobe Premiere Pro clip.

2 Save the project when you’re prompted by After Effects. Then, work in the 
composition just as you’d work in any other After Effects project. 

3 When you’re finished, save the project, and return to Adobe Premiere Pro. 

Your changes are automatically reflected in the timeline.
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Don’t worry about being exact about your brush strokes. Just make sure the matte 
is within 1 to 2 pixels of the edge of the foreground object. You’ll have an opportunity 
to re�ne the matte later. However, After E�ects uses the information on the base 
frame to adjust the matte for the rest of the span, so you want the matte to be accurate. 

15 Click the Toggle Alpha button ( ) at the bottom 
of the Layer panel. �e selected area is white 
against a black background, so you can see the 
matte clearly.

16 Click the Toggle Alpha Overlay button ( ) at 
the bottom of the Layer panel. �e foreground 
area appears in color, and the background has 
a red overlay.

17 Click the Toggle Alpha Boundary button ( ) at 
the bottom of the Layer panel to see the outline 
around the bird and rock pool again.

As you use the Roto Brush tool, the Alpha Boundary is the best way to see how 
accurate your boundary is, because you can see everything in the frame. However, 
the Alpha and Alpha Overlay options let you see your matte without the distraction 
of the background.

Re�ning the boundary across the span
You used the Roto Brush tool to create a base frame, which includes a segmentation 
boundary that divides the foreground from the background. �e Roto Brush span 
appears below the time ruler at the bottom of the Layer panel. When After E�ects 
has propagated the current boundary for a frame, the bar beneath that frame on the 
time ruler is green.

As you move forward and backward through the footage, the segmentation bound-
ary moves with the foreground object (in this case, the bird and the rock pool). 
You’ll step through the frames in the span and make adjustments to the segmentation 
boundary as necessary.

Because the rock pool is stationary, its track matte is consistent throughout the 
span. Given that, we’ll focus on the bird, which moves around a lot.
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1 Zoom in on the bird, and then make sure the Roto Brush tool is selected in the 
Tools panel. 

2 Press the 2 key on your main keyboard (not the numeric keypad) to move forward 
one frame.

Working from the base frame, After E�ects tracks the edge of the object and attempts 
to follow its movement. Depending on how complex your foreground and back-
ground elements are, the boundary may or may not conform exactly to the area you 
hoped it would. 

3 Using the Roto Brush tool, paint foreground and background strokes to re�ne the 
matte for this frame. If the matte is accurate, you don’t need to paint any strokes.

As you progress through this clip, you’ll notice changes to the segmentation bound-
ary with the bird’s beak. Likewise, you may need to re�ne the segmentation bound-
ary around the feet and legs.

▶Tip: To move 
forward one frame, 
press the 2 key on your 
keyboard; to move back 
one frame, press the 
1 key.

•Note: As it propa-
gates the segmentation 
boundary for a frame, 
After Effects caches that 
frame. Cached frames 
have a green bar in the 
time ruler. If you jump 
ahead to a frame 
further along the span, 
After Effects may take 
longer to calculate 
the boundary.
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4 Press the 2 key again to move forward to the next frame.

5 Use the Roto Brush tool to add to the foreground or subtract from the back-
ground as necessary to re�ne the boundary.

If you make a stroke you don’t like, you can always undo the stroke and try again. 
As you move through the span, each change you make a�ects the frames after it. 
�e more you re�ne your selection, the better the overall results will be. You may 
�nd it useful to move forward a few frames to see how changes a�ect the boundary.

When the bird is moving quickly (such as 0:14 –0:19), you’ll notice that the segmen-
tation boundary becomes more vague, but then “catches up” once the bird slows 
down again. When a frame displays rapid movement, focus on removing areas that 
should be excluded (such as the branch behind the bird), rather than adding blurry 
areas of the bird.

6 Repeat steps 4 and 5 until you reach the end of the layer.

7 Once you’re satis�ed with the bird, zoom out to �t the entire screen, and scroll 
though the span, making any adjustments as needed.

8 When you have completed re�ning the segmentation boundary for the entire 
layer, choose File > Save to save your work so far.
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Fine-tuning the matte
Roto Brush does a pretty good job, but there may be stray bits of background in the 
matte, or foreground areas that weren’t included. You’ll clean those up by re�ning 
the edge.

Adjusting the Roto Brush & Re�ne Edge e�ect
When you use the Roto Brush tool, After E�ects applies the Roto Brush & Re�ne 
Edge e�ect to the layer. You can modify the e�ect using settings in the E�ect 
Controls panel. You’ll use those settings to further re�ne the edge of the matte. 

1 Press the spacebar to play the clip in the Layer panel. Press the spacebar again 
to end the preview when you’ve seen the whole clip. 

As you preview the clip, you may notice that the segmentation boundary jumps 
around a bit. You’ll adjust the Reduce Chatter and Contrast settings to make it 
smoother.

2 In the E�ect Controls panel, decrease the Contrast to 40% and increase Reduce 
Chatter to 20%. 

�e Reduce Chatter value determines how much in�uence the current frame has 
when performing a weighted average across adjacent frames. Contrast a�ects how 
tight the boundary is. 

3 Preview the clip again. 
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Re�ne Soft Matte and 
Re�ne Hard Matte e�ects
After Effects includes two related effects for refining mattes: Refine Soft Matte and 
Refine Hard Matte. The Refine Soft Matte effect does the same thing as Refine Edge 
Matte, except it applies the effect to the entire matte at a constant width. If you 
need to capture subtle variations across an entire matte, use this effect.

The Refine Hard Matte effect performs the same edge refinements as the Roto Brush 
when Fine-Tune Roto Brush Matte is turned on in the Roto Brush & Refine Edge 
effect in the Effect Controls panel.

Using the Re�ne Edge tool
When an object isn’t smooth, the Roto Brush may not pick up the nuanced edge. 
�e Re�ne Edge tool lets you include �ne details such as wisps of hair in designated 
areas of the segmentation boundary. 

�ough it might be tempting to use the Re�ne Edge tool immediately after creat-
ing the base frame, it’s best to wait until you’ve re�ned the segmentation boundary 
across the entire clip. Because of the way After E�ects propagates the segmentation 
boundary, using the Re�ne Edge tool too early results in a matte that is di�cult to use.

1 Go to the base frame, which is the �rst frame of the clip, and then zoom in so 
that you can see the edges of the bird’s tail clearly. Use the Hand tool if necessary 
to move the layer so you can see the entire bird.

2 Select the Re�ne Edge tool ( ), hidden beneath the Roto Brush tool in the 
Tools panel.

�e tail is relatively soft, so a small brush size will work well. For a fuzzier object, 
you might have better results with a much larger brush. �e brush needs to overlap 
the stray edges that emerge from the object.

3 Change the brush size to 5 pixels. 

When you use the Re�ne Edge tool, draw strokes along the edges of the matte.

4 In the Layer panel, move the Re�ne Edge tool over the edge of the tail straddling 
the segmentation boundary and including the variations in the feathers. You can 
use multiple strokes if needed.
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When you release the mouse, After E�ects switches to the Re�ne Edge X-ray view 
so that you can see how the Re�ne Edge tool changes the matte, capturing the detail 
in the edges. 

5 Move the current-time indicator across the time ruler to view the edge. At 0:15, 
Re�ne Edge breaks away from the tail as the bird moves away rapidly. 

6 Change the brush size to 19 pixels.

7 At 0:15, press Alt (Windows) or Option (macOS) and erase the artifact from the 
Re�ne Edge tool, as it’s no longer useful going forward.

8 Continue to move forward and backward through the scene, applying the Re�ne 
Edge tool wherever the matte’s edge doesn’t capture the fuzziness of the bird’s 
feathers, and removing it wherever it strays from the tail.

9 Zoom out to see the entire scene, resize the Layer panel if you enlarged it, and then 
choose File > Save to save your work.

•Note: Use the 
Refine Edge tool only 
after you have cleaned 
up the matte across the 
entire clip.
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Freezing your Roto Brush tool results
You’ve put a fair amount of time and e�ort into creating the segmentation boundary 
across the entire clip. After E�ects has cached the segmentation boundary so it can 
recall it without having to make the calculations again. To keep that data easily 
accessible, you’ll freeze it. �is reduces the processing demands on your system 
so you can work faster in After E�ects.

Once the segmentation is frozen, you cannot edit it unless you unfreeze it. Refreezing 
the segmentation is time-consuming, so it’s best to re�ne the segmentation boundary 
as much as possible before freezing.

1 Click the Freeze button in the lower right area of the Layer panel. 

After E�ects displays a progress bar as it freezes the Roto Brush and Re�ne Edge tool 
data. Freezing may take a few minutes, depending on your system. As After E�ects 
freezes the information for each frame, the cache line turns blue. When it has �nished 
freezing, a blue warning bar appears above the time ruler in the Layer panel, remind-
ing you that the segmentation is frozen.

DDepending 
on your system, 
this may take 
a while.
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2 Click the Toggle Alpha Boundary button ( ) in the Layer panel to see the matte. 
�en click the Toggle Transparency Grid button ( ). Move the time marker across 
the time ruler to see the subject without the distractions of the background.

3 Click the Toggle Alpha Boundary button again to see the boundary.

4 Choose File > Save. 

After E�ects saves the frozen segmentation information with the project.

Changing the background
�ere are many reasons to isolate a foreground image from a background. You 
may want to replace the background entirely, moving the subject to a di�erent 
setting. Or you could simply want to change the foreground or background 
without modifying the other. In this lesson, you’ll remove the fenced in area of the 
background, and replace it with a di�erent background, which you’ll enhance with 
color correction tools.

1 Close the Layer panel to return to the Composition panel, and then move 
the current-time indicator to the beginning of the timeline. Choose Fit from 
the Magni�cation Ratio pop-up menu at the bottom of the Composition panel.

2 Hide the properties for the Chickadee.mov layer, if they’re visible.

�e Composition panel displays the composition, which includes only the 
Chickadee.mov layer, consisting only of the foreground you isolated from the clip. 

3 Click the Project tab to display the Project panel, and double-click an empty area 
in the Project panel. Navigate to the Lessons/Lesson09/Assets folder, select the 
MillPond.mov �le, and click Import or Open. 
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4 Drag the MillPond.mov clip from the Project panel to the Timeline panel, and 
place it below the original Chickadee.mov layer.

5 Click the new layer, press Enter or Return, and rename the layer Mill Pond 
Start. �en press Enter or Return again.

6 Select the Chickadee layer. �en, using the Selection tool ( ), drag the layer to 
the lower half of the Composition panel. Your values should be similar to ours.

7 Select the Mill Pond Start layer, and choose E�ect > Color Correction > 
Hue/Saturation.

You’ll use the Hue/Saturation e�ect in two di�erent ways, so you’ll create a duplicate 
layer for the second e�ect.

8 With the Mill Pond Start layer selected, choose Edit > Duplicate. Rename the 
bottom layer Mill Pond End. �en rename the top layer to remove the number 2 
from the name (so that its name is Mill Pond Start). 
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9 Select the Mill Pond Start layer, and then, in the E�ect Controls panel, do the 
following:

• Select Colorize.

• Change Colorize Hue to 56 degrees.

• Change Colorize Saturation to 19.

• Change Colorize Lightness to −25.

10 In the Properties panel, click the stopwatch icon for the Opacity value to create 
an initial keyframe at 100%.

11 Go to 1:10, and change the Opacity to 0.
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12 Still at 1:10, select the Mill Pond End layer.

13 In the E�ect Controls panel, click the stopwatch icon for the Channel Range 
property to create an initial keyframe.

14  Go to the end of the footage (2:25), and change the Master Hue to -30.

15 Press the spacebar to preview the project. Press the spacebar again when you’ve 
�nished.

�e background transitions from a monochromatic dusk to a full summer day and 
then again to the beginning of fall as the leaves change.

16 Choose File > Increment And Save. 

If you save incrementally, you can return to earlier versions of your project to make 
adjustments later. �is can be very useful if you’re experimenting or want to try 
alternative e�ects. �e Increment And Save feature preserves the previously saved 
version of the project and creates a new project with the same name, with an 
increasing number added to the �lename. 

Adding animated text
You’re nearly done. All you need to do is to add the animated title between the bird 
and the background. 

1 Deselect all layers, and then move the current-time indicator to the beginning 
of the time ruler.

2 Select the Type tool ( ), and then type Re�ections in the Composition panel.
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A new text layer named Re�ections appears in the Timeline panel at the top 
of the layer stack.

3 Select the Re�ections layer, and then do the following in the Text section 
of the Properties panel:

• Choose Courier New for the font.

• Choose Bold for the font style.

• Type 300 px for the font size.

• Choose Optical from the Kerning menu.

• Select white for the Fill color.

• Deselect the Stroke checkbox.

4 Click the More button, and then type 140% for the vertical scale.

5 Use the Selection tool ( ) to reposition the text to rest along the top edge of 
the rock pool, and then move the Re�ections layer below the Chickadee layer.

You’ll animate the text so that it appears on the screen in a liquid motion. 
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6 Make sure you’re at the beginning of the timeline and the Re�ections layer is 
selected. In the E�ects & Presets panel, type blur in the search box. Under Text, 
double-click the Blur And Fade In preset. 

7 Deselect all layers in the Timeline panel, and move the current-time indicator 
to the beginning of the time ruler. Press the spacebar to preview the clip. 

8 Choose File > Save to save your work.
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Outputting your project
You’ll render your movie to complete the project. 

1 Choose File > Export > Add To Render Queue.

2 In the Render Queue panel, click the blue words Best Settings.

3 In the Render Settings dialog box, choose Half from the Resolution menu, and 
make sure Use Comp’s Frame Rate is selected in the Frame Rate area. �en 
click OK.

4 Click the blue text next to Output Module. �en, at the bottom of the Output 
Module Settings dialog box, choose Audio Output O�, and click OK.

5 Click the blue text next to Output To. In the Output Movie To dialog box, 
navigate to the Lessons/Lesson09/Finished_Project folder, and click Save.
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6 Click Render in the top right corner of the Render Queue panel.

7 When the project has rendered, save and close it. 

Congratulations! You’ve separated a foreground object from the background, 
replaced and modi�ed the background, and animated some text to complete the 
movie. You’re ready to use the Roto Brush tool on your own projects.
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Extra credit

Tracking faces

The face-tracking feature in After Effects makes it easier to track a face or specific facial features, such 
as lips or eyes. Previously, tracking a face required roto brushing or complex keying. 

•Note: If you open the Lesson09_extra_credit.aep file, you may need to relink the Facetracking.mov asset.

1 Choose File > New > New Project.

2 Click the New Composition From Footage button in the Composition panel, and then navigate 
to the Lessons/Lesson09/Assets folder. Select the Facetracking.mov file, and click Import or Open.

3 Select the Facetracking.mov layer in the Timeline panel. Then, select the Ellipse tool, hidden by the 
Rectangle tool in the Tools panel. 

4 Drag an elliptical mask roughly covering the face.

5 Right-click the Mask 1 layer, and choose Track Mask. 

6 In the Tracker panel, choose Face Tracking (Outline Only) from the Method menu. 

The Face Tracking (Outline Only) option tracks the entire face. The Face Tracking (Detailed Features) 
option tracks the outline plus the lips, eyes, and other distinctive facial features. You can export 
detailed facial data for use in Character Animator, or you can use it in After Effects to apply effects 
or to match it with another layer, such as an eye patch or a hat.

(continued on next page)
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Sidebar head
Sidebar Text

Extra credit (continued)

7 Click the Track Forward button in the Tracker panel. 

The Tracker tracks the face, changing the mask’s shape and position as the face moves. 

8 Press the Home key to return to the beginning of the timeline, and then move the current-time 
indicator across the time ruler to see how the mask moves with the face.

9 In the Effects & Presets panel, search for Bright. Then drag the Brightness & Contrast effect onto 
the Facetracking.mov layer in the Timeline panel.

10 Expand Effects > Brightness & Contrast > Compositing Options in the Timeline panel. 

11 Click the + icon next to Compositing Options. Choose Mask 1 from the Mask Reference 1 menu, 
and increase Brightness to 50.

The masked area of the face brightens, but nothing else does. This setting is too bright, and the edge 
of the mask is too abrupt. You’ll make it more subtle. 

12 Reduce the Brightness to 20. 

13 Expand the Mask 1 properties. Change the Mask Feather property to 70, 70 pixels. 

14 Save the project to the Lessons/Lesson09/Finished_Project folder. Then close the file.

You can use the face tracker to blur a face, brighten it, or add any other effect. You can also invert 
the mask to affect everything but the face. 
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Review Questions
1 Review uses Number List

Review questions
1 When should you use the Roto Brush tool?

2 What is the segmentation boundary?

3 When should you use the Re�ne Edge tool?

Review answers
1 Use the Roto Brush tool any time you would have used traditional rotoscoping. 

It’s particularly useful for removing a foreground element from the background.

2 �e segmentation boundary is the boundary between the foreground and background. 
�e Roto Brush tool adjusts the segmentation boundary as you progress through the 
frames in the Roto Brush span.

3 Use the Re�ne Edge tool when you need to rotoscope objects with fuzzy or wispy edges. 
�e Re�ne Edge tool creates partial transparency for areas of �ne detail, such as hair. 
Use the Re�ne Edge tool only after you’ve adjusted the segmentation boundary across 
the entire clip.
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INDEX

SYMBOLS

3D

adjusting depth of �eld  337

cameras  316–317, 329–330

camera tools  310

channel e�ects  321

features  298–323

ground plane  303

layers  300, 302

light layers  312

point of interest  318

Real-time Draft 3D preview 
mode  303

Rotation properties  302

using HDR images as lights  316

views  308–309

3D Camera Tracker e�ect  326–344

3D models, importing  305–306

3D shapes

creating  301–302

extruding  303

3D text

creating  307

extruding  308

3D Transform Gizmo  302, 304

.mogrt �les

opening in After E�ects  292

opening in Premiere Pro  295–296

A

action-safe zones  24

activating fonts in 
Adobe Fonts  2, 60–62

adjustment layers  47, 140, 285

Adobe After E�ects application

installing  2

optimizing performance in  3

workspace  10

Adobe After E�ects Classroom 
in a Book 2024 Release

downloading lesson �les  4

prerequisites  2

Adobe After E�ects Help  36

Adobe Audition  144

Adobe Bridge

about  69

browsing animation presets in  68

importing �les with  69

installing  2

Adobe Character Animator  218
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Adobe Fonts  2, 60–86

Adobe Illustrator �les, 
importing  43

Adobe Media Encoder

creating presets 
for  397–400

encoding presets in  396

installing  2

rendering output 
with  394–399

Adobe Photoshop �les

importing  14, 150

importing layer styles 
from  155

importing text from  71

layered  149

Adobe Premiere Pro

Motion Graphics 
templates in  295

using with 
After E�ects  227

Adobe Stock  119

Advanced 3D renderer  302

Advanced pins

about  208

animating  214

placing  210

using to animate 
video  215–216

alpha track mattes. 
See track mattes

ambient lights, adding  343

Analyze Forward button  361

anchor points

adjusting  121

centering in shape layers  92

animating

cameras  320

facial expressions  218

�ll color  105

layers  146–179

layers to match audio  114

lighting  151–152, 163–167

on a path  129

opacity  77

position  83–85, 103

precomposed layers  139

Puppet tool pins  216

scale  65, 103

text  58–87, 71, 81, 238

video with Puppet 
tools  215–216

animation presets

applying  25–26, 48, 50

Bad TV 3 - weak  286

browsing in 
Adobe Bridge  68

customizing  70

Explosion 2  284

Fade Out By Character  79

Fade Up Words  25

Fly in with a Twist  205

Increase Tracking  75

Raining Characters In  73

Ripple  68

Slow Fade On  206

text  67

Typewriter  284

animations

about  22

creating with Character 
Animator  218

duplicating using pick 
whips  153

easing  67

linking through 
expressions  156

repeating  133

animator properties in text 
animator groups  81

application window  10

assets, importing  13

audio

adding tracks  143

animating layers 
to match  114

editing �les in Adobe 
Audition  144

�le formats supported  142

Audio/Video Switches in the 
Timeline panel  27

Audition. See Adobe Audition

Auto Contrast e�ect  19–20, 
254–255, 261
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B

background, 
replacing  235, 257–260

background strokes, 
creating with the 
Roto Brush tool  226–227

Bad TV 3 - weak animation 
preset  286

base frames, creating with the 
Roto Brush tool  224–225

Bend pins

about  208

animating  214

placing  210

Bezier curves

in a motion path  130

in masks  186

Bezier masks, creating  188

bicubic scaling  349

bilinear sampling  349

Black Clip  261

blending modes

about  196

applying  196

for masks  185, 258

blur, adding. 
See motion blur, adding

Bridge. See Adobe Bridge

Brightness and Contrast 
e�ect  268–269

brightness, changing 
in the user interface  35

Browse Presets command  68

Bullet Train animation 
preset  48

C

cached frames, using 
Roto Brush tool  229

Cache Frames When Idle  32

cameras

adding to a 3D scene  
316–317

animating  320

CC Light Sweep e�ect  21–22

CC Particle Systems II 
e�ect  367–378

Center Anchor Point In New 
Shape Layers  92

Channel Blur e�ect  28–29

Character Animator  218

Character panel  25, 44, 63

child layers  110

Cinema 4D Lite  322

circles, drawing  197

cloning objects  261–265

codecs  395

collaboration tools  36

color

animating  105

changing for a shape  92

correcting  248–276

correcting using Auto 
Contrast  261

grading  248

keying  222

previewing accurately  250

Color Emboss e�ect  47

Colorizing an image  255–257

Composition Navigator bar  23

Composition panel

about  15

typing in  63

Composition Pro�ler  167

compositions

about  15

adding footage to  16, 42

creating  15, 40–41, 59, 281

creating from footage  90

de�ned  12

duration of  41

�tting layers to  42

importing  13

nesting  16

rendering  52

retiming  168–177

Composition Settings 
dialog box  16–17, 41
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compression  395

Content-Aware Fill  363–367

contrast, adjusting  254–255

Convert To Editable Text 
command  24, 72, 205

Convert Vertex tool  187–188

copying. See duplicating

Corner Pin e�ect  161–162

Create Nulls From Paths panel  
110–111

Create Text And Camera 
command  330

Creative Cloud Libraries

about  119

sharing Motion Graphics 
templates in  292–293

current-time indicator  27

customizing

brightness of the user 
interface  35

workspaces  34

custom shapes, 
drawing  98–100

Custom View 1, 
in 3D views  310

D

default preferences  3, 11

deforming video with Puppet 
tools  215–216

Deform pins. See Puppet tools

Density value for Puppet 
tools  212

dependencies, �nding 
missing  14

depth of �eld, 
adjusting  337–338

Directional Blur e�ect  137

Dissolve-Ripple e�ect  343

distortions, rolling 
shutter  328

docking panels  10

Dolly controls  310

downloading lesson �les  4

drawing

circles  373

custom shapes  98

ellipses  197

rounded rectangles  100

shapes  91

stars  92

with the Pen tool  106

drift, in motion tracking  363

Drop Shadow e�ect  46

drop zone  10

duotones, creating  255–257

duplicating

animations  133

animations using pick 
whips  153

shape layers  95

videos  135

duration

about  26

setting for composition  41

E

Easy Ease

adding  67

in the Graph Editor  383

editing

masks  185

Premiere Pro clips in After 
E�ects  227

segmentation 
boundaries  228–231

text  25, 44–45, 72

E�ect Controls panel

about  46

hiding properties in  22

e�ects

about  18

applying  47, 136

Auto Contrast  19–20, 261

Brightness and 
Contrast  268–269

CC Light Sweep  21–22

CC Particle 
Systems II  367–378

Channel Blur  28–29

Color Emboss  47

controlling  47

Corner Pin  161–162

Directional Blur  137

disabling third-party  402

Dissolve-Ripple  343

Dissolve - Vapor animation 
preset  50–51

Drop Shadow  46

Fade Up Words  26

�nding  20
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Fractal Noise  137

Gaussian Blur  372

Hue/Saturation  236, 252–
254, 255–257

Lens Flare  376

missing  14

motion blur  85

Ramp  375

Re�ne Hard Matte  232

Re�ne Soft Matte  232

Timewarp  379

Wave Warp  140

E�ects & Presets panel  20

Ellipse tool

creating a vignette with  197

using to create 
a mask  197, 373

encoding presets in 
Adobe Media Encoder  396

Essential Graphics panel

about  280, 286

adding properties
 to  287–292

editing source text in  287

exporting templates 
from  292–293

grouping properties in  289

in Premiere Pro  295

organizing  289

viewing supported 
properties  288

Essential Graphics 
workspace  287

essential properties  294

exporting

Motion Graphics 
templates  292–293

movies with Adobe Media 
Encoder  394–400

expressions  156, 264

extruding

3D shapes  303

text  308

F

face tracking  243

Fade Out By Character 
animation preset  79

Fade Up Words animation 
preset  26

�les, importing  11

�lls  92

�ltering in Adobe Fonts  61

�nding missing footage, fonts, 
or e�ects  14

Fit To Comp command  42

Fit To Comp Width 
command  64

Fly in with a Twist animation 
preset  205

fonts

�nding missing  14

installing from Adobe 
Fonts  2, 60–62

selecting  63

footage

about  13

�nding missing  14, 402

importing  12, 14, 148

tracking  328

foreground strokes, 
creating with the Roto 
Brush tool  225–226

formatting text  63–64

Fractal Noise e�ect  137

freezing

frames  270, 273–274

Roto Brush tool results  234

G

Gaussian Blur e�ect  372

gradient �lls  92

Graph Editor

about  172

using to remap 
time  173–177, 383

grids

displaying and hiding  45, 65

snapping to  65

ground plane

creating with 3D Camera 
Tracker e�ect  329

viewing in 3D projects  303

grouping properties in the 
Essential Graphics panel  289

guides, showing  45
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H

HDR (high dynamic range) 
footage  378

HDR images as lights  316

hiding properties  22

Home key  25

Home window  11, 36

Horizontal Type 
tool  25, 44, 75

Hue/Saturation e�ect  
236, 252–254, 255–257

I

Illustrator �les, 
importing  42–43

images

adding to 3D scenes with 
3D Camera Tracker  336

replacing in motion 
graphics templates  290

importing

3D objects  305

footage  12, 13, 14, 148

layered Illustrator 
�les  42–43

layered Photoshop �les as 
compositions  13, 23, 
148–150

multiple �les  13

Photoshop �les  13, 71, 150

text  71–72

Increase Tracking animation 
preset  75

Increment And Save 
command  238

In points, setting  27, 141

installing

After E�ects  2

fonts  60–62

interpolation between 
keyframes  28

J

JavaScript in expressions  156

K

keyframes

about  28, 29

adding  127

labels  132

keying  222

L

labeling keyframes  132

layers

about  15, 17

adjustment  140

animating  146–179, 149

animating to match 
audio  114

child  110, 123

converting to 3D  302

copying  127

expanding in the Timeline 
panel  19

�tting to compositions  42

importing in Photoshop 
�les  149

isolating  161

locking  204

making visible in the 
Timeline panel  30

naming in Photoshop  150

naming text  44

nesting  49

parenting  109, 110, 123

precomposing  
49, 98, 125, 270–271

rearranging in the 
Timeline panel  18

renaming  73

scaling  206

setting In points for  141

shape  88–115, 91

shortening  141

snapping  100

solid  136, 165

soloing  161

splitting with Scene Edit 
Detection  251–252

text  60

Transform properties  18–19

trimming  141, 285

layer styles  155

Layer switches in the Timeline 
panel  27

learning resources for Adobe 
After E�ects  6

Learn panel  36
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length of composition  41

Lens Flare e�ect  376

lesson �les, downloading  4

Libraries panel  119

lighting, simulating changes 
in  151–152, 163–167

lights

adding 3D  312

using HDR images as  316

Light Settings dialog box  313

linked assets  14

linking animations through 
expressions  156

locking layers  204

M

Mask Feather tool  194

masks

about  182

Bezier  186, 188

creating  364–365

creating with the Pen 
tool  163–164, 184

curved  186

drawing with shape 
tools  197

editing  185

feathering  194

inverting  185

modes  165, 185, 258–259

modifying with the 
Convert Vertex tool  187

properties, displaying  185

replacing content of  188

segments  182

tips for creating  184

tracking  257

tracking faces  243

vertices  182

working with  180

mask tracker  257–259

Material Options 
properties  315

mattes

about  222

adjusting with the Re�ne 
Edge tool  232–233

track  156–159, 159

traveling  159

viewing against black  228

viewing with red 
overlay  228

Maxon Cinema 4D 
Lite  322–323

Media Encoder. 
See Adobe Media Encoder

meshes

adjusting the Density 
value  212

changing the color of  211

used with Puppet tools  208

missing fonts, e�ects, 
or footage  14, 402

mobile devices, preparing 
compositions for  392

Mocha AE plug-in  367

modes, mask  185

motion blur, adding  85, 160

Motion Graphics templates

about  280

creating  278–297

exporting  292–293

grouping properties in  289

making source text 
editable in  287

opening in After E�ects  292

replacing images in  290

sharing  280

specifying master 
compositions for  286

using in Premiere Pro  295

motion paths, customizing  129

Motion Source  360

Motion Target  360

motion tracking

analyzing and applying  361

managing drift when  363

single-point  356–362

N

nesting compositions  16, 49

New Composition button  281

New Composition from 
Footage button  90

NTSC D1 preset  41

null objects  110–111
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O

O�set Paths in shape layers  97

opacity

animating  77, 191

modifying  51

optimizing performance 
in After E�ects  3, 33

Orbit tools  310

Out point  27

output modules in the 
Render Queue panel  53

outputting projects  386–401

overlap, de�ning areas of  212

Overlap pins  208

overscan  24

P

Pan Behind tool  122

panels

docking and arranging  10

maximizing  12

menus  27

panning with touch 
gestures  189

Pan tools  310

paragraph text  60

parenting

about  110

layers  109, 123

layers to null 
objects  110–111

particle systems, 
creating  367–378

path operations

about  102

Pucker & Bloat  102

Wiggle Paths  93

Pen tool  98, 106, 184

performance, optimizing  3, 33

Photoshop. 
See Adobe Photoshop �les

pick whip  153

pixel aspect ratio  400

point of interest  318

point text  63

position, animating  83, 103

positioning objects using ruler 
guides  45

Position pins

adding  208–210

animating  214

Position property  19

Pre-compose 
dialog box  49, 125

precomposed layers, 
animating  139

precomposing layers  49, 98, 
125, 169–170, 270–271

preferences

Center Anchor Point In 
New Shape Layers  92

location of �les  3

restoring defaults  3, 402

restoring defaults 
in Windows  11

Premiere Pro. 
See Adobe Premiere Pro

presets

browsing in 
Adobe Bridge  68

creating for Adobe Media 
Encoder  397–400

�nding  20

previewing

compositions  30

in real time  32

manually  48

Preview panel  30

Project panel

about  14

opening  53

projects

about  12

saving  15

properties

grouping in the Essential 
Graphics panel  289

hiding in the Timeline 
panel  22

Properties panel

about  30

essential properties in  294

formatting text in  63

shape settings in  99

Pucker & Bloat  102–103
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Puppet tools

about  207

distorting objects 
with  200–219

Puppet Advanced Pin 
tool  208, 210–211

Puppet Bend Pin 
tool  208, 210

Puppet Overlap Pin 
tool  208, 212

Puppet Position Pin 
tool  208

Puppet Sketch 
tool  216–217

Puppet Starch Pin 
tool  208, 213–217

recording animation 
with  216

using the mesh  208

Q

QuickTime  2

R

Raining Characters 
In animation preset  73

Ramp e�ect  375

recording puppet pin 
animation  216

Rectangle tool  197

red overlay in matte 
preview  228

Reduce Chatter value  231

Re�ne Edge tool  232–233

Re�ne Hard Matte e�ect  232

Re�ne Soft Matte e�ect  232

re�ections, adding  191

remap-time marker in the 
Source Time ruler  171

removing objects from 
footage  363–367

rendering

compositions  52–54

default settings for  53

for mobile devices  392

movies  386–401

templates  393

using compression in  395

using the Render Queue 
panel  242, 389–395

with Adobe Media 
Encoder  394–399

Render Queue 
panel  241, 393–400

adding compositions to  53

Render Settings options  53

render-settings 
templates  393–397

render times, by layer  167, 402

replacing

backgrounds  257–260

content using a mask  188

content with content-
aware �ll  363–367

resetting preferences  402

resizing layers  206

resources for using 
After E�ects  36

Responsive Design - 
Time  291–292

restoring default 
preferences  3, 11

retiming compositions  
168–177, 379

Ripple animation preset  68

rolling shutter distortions, 
repairing  328

Roto Brush & Re�ne Edge 
e�ect  231

Roto Brush tool

creating background 
strokes  226–227

creating foreground 
strokes  224–225

freezing results  234

re�ning a segmentation 
boundary  228–231

using  220–245

rotoscoping  222

Rounded Rectangle tool  100

rulers, showing  45

S

Safe Mode  402

safe zones  25

sample text, using 
in Adobe Fonts  61

sampling algorithms  349



412 INDEX

saturation, adjusting  252–254

saving projects  15

scale

animating  65, 103

modifying  206

Scene Edit Detection  251–252

segmentation boundary  
224–227

segments in a mask  182

selectors in text animator 
groups  81

Select View Layout pop-up 
menu  309

separating background from 
foreground  222–245

Sequence Layers 
command  275

shadow catcher  343

shadows

adding to a 3D scene  315

creating with the 
3D Camera Tracker 
e�ect  341

simulating  191

shape layers

3D  301–302

about  88, 90

applying �lls and 
strokes to  92

centering anchor 
points in  92

creating  91

duplicating  95

settings in Properties 
panel  99

shapes

custom  98–100

drawing  91, 98

self-animating  93

shared projects  36

Shutter Angle  160

Shutter Phase  160

Slow Fade On animation 
preset  206

snapping layers  100–104

Snap to Grid command  65

solid layers

creating  136, 165

using to create particle 
systems  369

using with 3D Camera 
Tracker  336–337

soloing layers  161

Solo Supported Properties 
in the Essential Graphics 
panel  288

soundtrack, adding  143

Source Text property  287

Source Time ruler in time 
remapping  171

Specular Intensity  315

Specular Shininess  315

split layers by scene  251

squares, drawing  197

squash and stretch 
animation  213

stabilizing video  348–355

stacked panels  10

Starch pins

about  208

adding  213

Star tool  92

Startup Repair Options 
dialog box  402

Stock images in Libraries 
panel  119

strokes  93

tapering  107

Sync Selected Fonts  62

T

team projects  36

templates

for rendering  393–397

Motion Graphics  286–287

text

3D  307–308

adding  60–65, 282

animating  58–87, 71, 81, 
238–240, 282–284

animating tracking in  75

animation presets 
for  25–26, 67

converting to 
editable  23–24, 72, 205

creating  44

editing  44, 72

editing imported  205

entering in the 
Composition panel  63

formatting  63–64, 282
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imported from 
Photoshop  71

layers  60

making editable in Motion 
Graphics templates  287

naming layers  44

point  63

positioning  64

settings in the Properties 
panel  63, 307

text animator groups  80

time. See Timewarp e�ect

current-time �eld  27

current-time indicator  27

duration  26

freezing frames  273–274

protecting 
duration  291–292

remapping  170–174

ruler  27

timecode  26

time graph  27

time-lapse simulation, 
creating  168

Timeline panel

about  27

expanding layers in  19

renaming layers in  73

Time Remap keyframes  173

Timewarp e�ect  379–384

title-safe zones  24

Toggle Alpha Boundary 
button  228

Toggle Alpha button  228

Toggle Alpha Overlay 
button  228

Toggle Transparency Grid 
button  235

tools

about  24

Clone Stamp  262–264

drawing  91

Ellipse  197

Pan Behind  122

Puppet  207

Rectangle  197

Tools panel  24

touch gestures  189

Track Camera command  329

Tracker panel  259

tracking in type, animating  75

tracking motion

faces  243

single-point  356–362

using Mocha AE  367

using the 3D Camera 
Tracker  328–329

with masks  364–365

tracking presets  76

track mattes  156–159

track points

for 3D Camera Tracker  329

moving and resizing  359

positioning  358–360

training, Adobe product  7

Transform properties  19

transitions between 
scenes  274–275

transparency  51. 
See also opacity

traveling mattes  159

trimming layers  141, 285

tutorials, accessing  6, 36

type. See text

Typewriter animation 
preset  284

U

U key  74

undocking panels  10

Use Dimensions From 
menu  16

user interface

about  10

customizing brightness  35

V

vertices

converting  187

in a mask  182

Video switch  30, 50

views, 3D  308

vignettes, adding  196, 267
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W

Warp Stabilizer VFX  348–355

Wave Warp e�ect  140

Web Edition  4

White Clip  261

Wiggle Paths  93

work area

brackets  27

introduction to  10

work�ow  11

workspaces

about  10

customizing  10, 34

Essential Graphics  287

Learn  36

prede�ned  34

X

x axis in the 3D Transform 
Gizmo  302

Y

y axis in the 3D Transform 
Gizmo  302

Z

z axis in the 3D Transform 
Gizmo  302

zooming with touch gestures  
189
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