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4 CREATING AND 
EDITING GRAPHICS

Lesson overview
In this lesson, you’ll learn how to do the following:

• Create and edit shapes.

• Change the fill and border of content.

• Combine shapes using Boolean operations.

• Draw with the Pen tool.

• Edit paths and shapes.

• Work with UI kits.

This lesson will take about 60 minutes to complete. To get the lesson files 
used in this chapter, download them from the web page for this book at 
www.adobepress.com/XDCIB2020. For more information, see “Accessing 
the lesson files and Web Edition” in the Getting Started section at the 
beginning of this book.

http://www.adobepress.com/XDCIB2020
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Aside from creating artwork using the shape tools in 
Adobe XD, you can also create artwork using the Pen 
tool. With these tools, you can precisely draw straight 
lines, curves, and more complex shapes.
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Starting the lesson
In this lesson, you’ll create vector shapes in the form of buttons, icons, and other 
graphic elements. To start, you’ll open a final lesson file to get an idea of what you 
will create in this lesson.

1 Start Adobe XD, if it’s not already open.

2 On macOS, choose File > Open From Your Computer. On Windows, click the 
menu icon ( ) in the upper-left corner of the application window and choose 
Open From Your Computer. Open the file named L4_end.xd, which is in the 
Lessons > Lesson04 folder that you copied onto your hard disk.

� Note: For either macOS or Windows, if the Home screen is showing with no files open, click Your 
Computer in the Home screen. Open the file named L4_end.xd, which is in the Lessons > Lesson04 
folder that you copied onto your hard disk. 

3 If the Assets panel opens on the left and you see a Missing Fonts message, close 
the Assets panel by clicking Assets panel icon ( ) in the lower left. 

4 Choose View > Zoom To Fit All (macOS) or Zoom To Fit All from the Zoom 
menu (Windows) in the upper right and leave the file open for reference.

This file shows you what you will create by the end of the lesson.

5 Leave the file open for reference, or choose File > Close (macOS) or click the X 
in the upper-right corner of the open window (Windows) to close the file.

� Note: If you 
have not already 
downloaded the project 
files for this lesson to 
your computer from 
your Account page, 
make sure to do so 
now. See the “Getting 
Started” section at the 
beginning of the book.
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Graphics and Adobe XD
In Adobe XD, you’ll create and work with vector graphics (sometimes called vector 
shapes or vector elements). Vector graphics are made up of lines and curves 
defined by mathematical objects called vectors and can be created in Adobe XD or 
a program like Adobe Illustrator. 

In Lesson 3, “Adding Images, Graphics, and Text” you learned about the different 
types of images you can import into Adobe XD and how to work with them, 
including bringing in vector artwork from Illustrator. Using a variety of methods 
and tools in Adobe XD, you can freely move or modify shapes or paths you import 
or create. These can be in the form of icons, buttons, and other design elements.

Creating and editing shapes
Creating vector artwork in Adobe XD is easy thanks to the array of drawing tools 
available. If you’re coming from other Adobe applications, you’ll find the drawing 
tools in Adobe XD to be streamlined and efficient, with a few differences. For more 
complex vector content, you can use Illustrator and easily bring the vector artwork 
into XD. 

1 Choose File > Open From Your Computer (macOS), or click the menu icon ( ) 
in the upper-left corner of the application window and choose Open From Your 
Computer (Windows). Open the Travel_Design.xd document in the Lessons 
folder (or where you saved it). 

2 Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the content.

3 Click the artboard name “Home” in the document window to select that 
artboard. Press Command+3 (macOS) or Ctrl+3 (Windows) to zoom in.

4 Select the Select tool ( ) and click away from the artboards to deselect all.

� Note: If you are 
starting from scratch 
using the jumpstart 
method described in 
the section “Getting 
Started,” open 
L4_start.xd from the 
Lessons > Lesson04 folder.
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Creating rectangles
In this section, using the Rectangle tool, you’ll create a rectangle that will be used 
as a button on the home screen.

1 Select the Rectangle tool ( ) in the toolbar. Near the bottom of the Home 
artboard, move the pointer over the left edge of the artboard until that edge 
of the artboard turns aqua. Th is change in color indicates that the shape will 
snap or align to the edge of the artboard. Drag down and to the right to draw a 
rectangle, stopping on the right edge of the artboard. When alignment guides 
appear on the right, release the mouse button. Don’t worry about the height 
for now.

Alignment guides are always on and can be very helpful for aligning, snapping, 
and spacing content you create or transform.

2 With the rectangle selected, drag the top-middle point of the shape up or down 
until you see a Height value of approximately 80 in the Property Inspector.

Drag to resize the rectangle The result in the Property Inspector

Similar to editing artboards, as you draw or edit shapes the Width and Height 
values in the Property Inspector change to refl ect the current sizing of the 
selected content. 

�	�	Tip: When drawing 
shapes, you can hold 
down Option (macOS) 
or Alt (Windows) to 
draw from the center, or 
press Shift to constrain 
the proportions of the 
shape. In the case of the 
Rectangle tool, pressing 
the Shift key constrains 
the shape to a square as 
you draw.

�	�	Tip: You can also 
press the R key to select 
the Rectangle tool.
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Creating ellipses
Another drawing tool you can use is the Ellipse tool. In this section, you’ll create 
several circles that will be used as a button in the app footer. 

1 Press Command+Shift+A (macOS) or Ctrl+Shift+A (Windows) to deselect all 
so that you will be able to see all of the artboards in the Layers panel.

2 Click the Layers panel button ( ) in the 
lower-left corner (or press Command+Y 
[macOS] or Ctrl+Y [Windows]) to open the 
Layers panel, if it isn’t already open. Double-
click the artboard icon ( ) to the left of the 
artboard name “Icons” in the Layers panel to 
fi t the artboard in the document window.

As you make your way through the lessons, 
you’ll see that there are a lot of ways to 
navigate between artboards. Th e Layers panel is a method that you learned 
about in Lesson 1, “An Introduction to Adobe XD.”

3 Choose Square from the Grid menu in the Property Inspector to turn it on. Click 
the Use Default button to apply the default square grid you set up previously.

Next you’ll create a record button that will be used on the Recording artboard.

4 Select the Ellipse tool ( ) in the toolbar (or press the E key to select the Ellipse 
tool). Hold down the Shift key and drag to create a circle on the artboard. As 
you drag, pay attention to Width and Height in the Property Inspector. When 
you see a width of 152 and height of 152, release the mouse button and then 
the key.

You may notice that as you drag, the Width and Height values are changing by 
multiples of 8. Th at’s due to the square grid setting of 8.

� Note: If you started 
with the L4_start.xd fi le, 
the default grid you see 
may not be the same. 
Ensure that Square Size 
is 8, and click the Square 
Size color to ensure that 
the Alpha value in the 
color picker is 20%.

�� Tip: You can press 
Command+’ (macOS) 
or Ctrl+’ (Windows) to 
show or hide the square 
grid for a selected 
artboard or artboards.
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5 Right-click the circle and choose Copy. Th en right-click and choose Paste to 
paste a copy directly on top of the original. 

6 To make the new circle half its size, drag a 
corner toward the center. As you drag, hold 
down Option+Shift (macOS) or Alt+Shift 
(Windows) to resize it from the center and 
maintain its proportions. Release the mouse 
button and then the keys.

Creating polygons
Th e last type of shape you’ll explore is the polygon. Using the Polygon tool, you’ll 
create a triangle shape that will be used on the Memory artboard.

1 Press Command+Shift+A (macOS) or Ctrl+Shift+A (Windows) to deselect all 
so that you can see all of the artboards in the Layers panel.

2 In the Layers panel, double-click the artboard icon ( ) to the left of the 
artboard name “Memory” to fi t the artboard in the document window.

3 To turn off  the square grid, deselect the Square option in the Grid section of the 
Properties panel. Th is allows you to draw without snapping to the square grid.

4 Select the Polygon tool ( ) in the toolbar.

5 Move the pointer in an empty area of the artboard. By default, the Polygon tool 
creates a triangle (a three-sided shape), but you’ll edit the shape as you draw it. 
Drag down and to the right to begin drawing a polygon, but don’t release the 
mouse button yet. Press the up arrow key twice to increase the number of sides 
on the polygon to fi ve, and don’t release the mouse button yet. Hold down the 
Shift key to straighten and constrain the shape. Release the mouse button and 
then the key. Leave the shape selected.

In the Properties panel, you will now see a Corner Count option ( ), the 
Corner Radius option ( ), and the Star Ratio ( ). Th e corner count is used 
to change the number of sides on the shape after you’ve created it, and the star 
ratio is used to turn the polygon into a star shape.
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6 Change the Corner Count option to 3 and press Return or Enter. Leave the 
triangle selected.

Creating stars
To create a star shape using the Polygon tool, start by drawing a polygon on the 
artboard.  Then, click the Star Ratio handle in the upper right corner of the polygon, 
and drag in towards the radius. You can also adjust the star ratio by clicking the 
Star Ratio fi eld in the Property Inspector. The ratio can be a value between 1 and 
100. Use the Corner Count fi eld to defi ne the number of sides you want to have for 
the polygon. You can draw a star polygon from a regular triangle and go up to a 
hundred-sided polygon. 

Hold down Shift key while dragging the Star Ratio handle to change it in increments 
of 10%. Alternatively,  place the cursor on the Star Ratio fi eld, and press the up and 
down arrow keys to control the ratio size.

—From XD Help
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Changing fill and border
Now that you have a few shapes in your design, you’ll start to change appearance 
properties for them. You’ll start by sampling color with the Eyedropper.

1 Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the content.

2 Select the Select tool ( ) in the toolbar. Shift-click the rectangle you drew 
toward the bottom of the Home artboard to select it and the triangle. 

3 Press the I key to select the fill Eyedropper so you can sample a color and apply 
it to the fill of selected content. Move the pointer over the orange-red color in 
the Countdown artboard and click to sample the color.

4 To save the orange-red color, click the Fill color in the Property Inspector and 
click the plus (+) at the bottom of the Color Picker. Press the Esc key to hide 
the panel.

5 Deselect the Border option to turn the border 
off for the selected shapes.

6 Click the larger circle you drew on the Icons 
artboard to select it. Press Command+3 
(macOS) or Ctrl+3 (Windows) to zoom 
in to it.

�� Tip: You can also 
click the Eyedropper 
to the right of the Fill 
box in the Property 
Inspector (circled in 
the figure) to be able 
to sample a color for 
the fill.
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7 Deselect the Fill option in the Property Inspector to remove the fill. 

8 Click the Border color to show the Color Picker. Change the border color to 
white by dragging in the Saturation/Brightness field.

9 Click the plus (+) at the bottom of the color picker to save the white color.

Fill and border colors you create can be saved in this way. The colors you save 
using this method appear in the color picker for this document only. You can’t 
give names to these saved colors.

10 Click to select the smaller circle and deselect the Border option to turn it off. 

11 Drag across both circles to select them, and choose Object > Group (macOS) or 
right-click and choose Group to keep them together as a group.

12 Press Command+S (macOS) or Ctrl+S (Windows) to save the file.

�	�	Tip: To delete a 
color swatch, drag the 
swatch away from the 
color picker window.
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Working with border options
Now, you’ll create a simple magnifying glass search icon from a circle and path. 
You’ll explore border alignment and changing the line cap to get the fi nal look.

1 Press Command and – (macOS) or Ctrl and – (Windows) a few times to 
zoom out.

2 Press the spacebar and drag to the left to see more of the Icons artboard to the 
right of the circles. You can also drag on a trackpad with two fi ngers to pan in 
the document window.

3 Select the Ellipse tool ( ) in the toolbar. Shift-drag to create a circle on the 
artboard. As you drag, pay attention to Width and Height in the Property 
Inspector. When you see an approximate width of 20 and height of 20, release 
the mouse button and then the key.

4 Deselect the Fill option in the Property Inspector to remove the fi ll. 

5 Click the Border color to show the Color Picker. Click the white color you saved 
previously to apply it to the border. Press the Esc key to hide the panel.

6 Change Border Size to 4 and press Return or Enter.

7 Click the Outer Stroke button ( ) to align the border to the outside of 
the shape.
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By default, borders are aligned to the inside of paths in Adobe XD. Next you’ll 
draw the handle of the search icon.

8 Press Command+Shift+A (macOS) or Ctrl+Shift+A (Windows) to deselect.

9 Select the Line tool ( ) in the toolbar on the 
left and Shift-drag to make a small angled 
line, as you see in the fi gure. Th is will be the 
handle of the magnifying glass. 

10 Change the border color to white, change the 
border size to 4, and press Return or Enter. Click the Round Cap button ( ) to 
round the ends of the line.

11 Select the Select tool and drag across both objects and press Command+G 
(macOS) or Ctrl+G (Windows) to group them.

Rounding corners
When it comes to rectangles, you can easily round all of the corners of a rectangle 
at once or each individually. In this next section, you’ll create a rounded-corner 
rectangle that will become part of an icon. 

1 With the Select tool ( ) selected, zoom out by pressing Command and – 
(macOS) or Ctrl and – (Windows).

To zoom in or out you can also pinch using a trackpad or Option-scroll/Alt-
scroll using a mouse.

2 Select the Rectangle tool ( ) in the toolbar and Shift-drag to create a square 
next to the search icon you just created. Release the mouse button and then 
the key when it shows an approximate width of 30 and height of 30 in the 
Property Inspector.

� Note: You may want 
to reposition the handle  
before you group the 
objects in the next step.
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3 Deselect the Border option in the Property Inspector to remove the border.

For the next step, you may need to zoom in to see the corner radius widgets.

4 Drag any one of the corner radius widgets ( ) toward the center of the shape to 
round all of the corners at once. Drag as far as you can to make a circle.

Next, you’ll round corners independently on a shape.

5 To duplicate the circle, press Command+D (macOS) or Ctrl+D (Windows). A 
copy is placed on top of the original.

6 Press the letter V to select the Select tool and 
drag the new circle straight down, away from 
the original, making sure they still overlap 
a little.

7 Option-drag (macOS) or Alt-drag (Windows) 
the middle point on the right side of the 
shape to the right to make the shape wider 
from both sides at the same time.

8 Change the Corner Radius value in the 
Property Inspector to 0 to remove the rounded corners from the copy. 

9 Option-drag (macOS) or Alt-drag (Windows) the upper-left corner radius 
widget ( ) toward the center of the shape. Drag until you see a Top Left Corner 
Radius value of approximately 30 in the Property Inspector.

�	�	Tip: You can drag 
any of the corner 
widgets on the shape 
away from the center 
of the shape to remove 
the corner radius.
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Dragging with the Option/Alt key held down allows you to change one of the 
corner radii. When you change a single corner radius by dragging with the 
Option/Alt key, the Diff erent Radius For Each Corner option ( ) becomes 
selected in the Property Inspector, allowing you to change each corner radius 
independently. If you fi nd that you can’t change the radius value to 30—maybe 
you can only change it to 26, for instance—it may be that the rectangle is 
smaller than it is in the fi gure. Th at’s okay.

10 Change the Corner Radius values in the Property Inspector to 50, 50, 30, and 
30 (or similar values) and press Return or Enter to accept the values. Leave the 
shape selected.

11 With the Select tool selected, drag across both objects and press Command+G 
(macOS) or Ctrl+G (Windows) to group them.

Editing shapes
If you’ve ever edited shapes in other Adobe programs, like Illustrator, you’re likely 
used to switching tools to accomplish shape editing tasks. In Adobe XD, shape 
editing is easily accomplished with a single tool, the Select tool. In this section, 
you’ll create and edit shapes for a map icon.

1 Choose View > Show Square Grid (macOS), or right-click the Icons artboard 
and choose Show Square Grid (Windows).

2 Select the Rectangle tool ( ) in the toolbar 
and, starting on the square grid, drag to 
create a rectangle that is wider than it is 
tall. Make sure to snap the right edge of the 
rectangle to the square grid. See the fi gure. 
Th e rectangle in the fi gure has a height of 40 
and a width of 72.

In this case, the square grid can be a useful way to create shapes because it 
ensures whole-number values for width and height. Every shape you create has 
a bounding box around it when selected. Th is is used for transforming the shape 
in diff erent ways. 

�	�	Tip: If you want to 
ensure that all of the 
radius values are the 
same again, you can 
click the Same Radius 
For All Corners 
button ( ).

� Note: By default, 
when you transform a 
shape, the corner radius 
values do not scale 
(change).
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3 Select the Select tool ( ) and double-click the selected rectangle.

Double-clicking an object enters Path Edit mode, which allows you to edit the 
anchor points of the object. At this point, you could select existing anchor 
points and edit or delete them and add new anchor points, but you can’t move 
or transform the entire shape.

4 Drag across the top two anchor points to select them both. You could have also 
pressed the Shift key and clicked both anchor points to select them. 

5 Drag one of the anchor points to the left, keeping it in line with the original 
position of the anchor points. Snap the anchor point you are dragging to the 
square grid.

6 Press the Esc key to exit Path Edit mode. The bounding box is now showing 
again, and the anchor points are hidden. 

7 With the shape still selected, move the pointer just off one of the corners. When 
the pointer changes ( ), Shift-drag clockwise to rotate the shape. When you see 
90 in the Rotation field of the Property Inspector, release the mouse button and 
then the Shift key.
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8 With the Select tool ( ) and the shape still selected, press Command+D 
(macOS) or Ctrl+D (Windows) to paste a copy right on top of the original.

Next, you’ll flip the shape copy.

9 Click the Flip Horizontally button ( ) in the Property Inspector to flip the shape.

10 Drag the shape you just flipped to the right. When there is a gap of 3 pixels 
between the shapes, stop dragging and release the mouse button. Aqua 
alignment guides appear, indicating it is still aligned horizontally with the 
original shape.

11 Option-drag (macOS) or Alt-drag (Windows) the shape on the left to the right 
to make a copy. When it looks like the figure, release the mouse button and then 
the key.

12 Drag across all three shapes and press Command+G (macOS) or Ctrl+G 
(Windows) to group them together and make a map icon. 

13 Deselect the Border option in the Property Inspector to remove the border.

� Note: If you find that 
the shape is snapping 
to the square grid and 
the Gap value you see 
is 8, try zooming in 
further. By zooming in, 
the shape will snap to 
the pixel grid and the 
square grid.
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Combining shapes
Like many other drawing applications, Adobe XD off ers several Boolean operations 
for combining shapes in diff erent ways. Th ere are four Boolean operations 
you can choose from: Add, Subtract, Intersect, and Exclude Overlap. Using 
Boolean operations can be very useful for creating more complex artwork from 
simpler shapes. To me, the best part of combining shapes using Boolean operations 
in Adobe XD is the ability to edit each individual shape, even after multiple shapes 
have been combined. Next, you’ll combine shapes to create a map pin icon.

1 Zoom out a bit by pressing Command and – (macOS) or Ctrl and – (Windows) 
a few times.

2 Select the Ellipse tool ( ) in the toolbar. In a blank area of the artboard, Shift-
drag to create a circle. Don’t worry about the size for now. Just make it large 
enough to work with. Release the mouse button and then the key.

3 With the Select tool ( ) and the shape still selected, press Command+D 
(macOS) or Ctrl+D (Windows) to paste a copy right on top of the original.

4 Option+Shift-drag (macOS) or Alt+Shift-drag (Windows) a corner to make the 
circle smaller.

5 Click the larger circle to select it. Double-click the shape to enter Path Edit 
mode and see the anchor points. See the fi rst part of the following fi gure.

6 Click the anchor point on the bottom of the circle to select it. You should see 
little direction handles appear on either side of the point. Th ese control the 
curve of the path on either side of the anchor point.

For the next step, if you don’t see the aqua alignment guide, you may need to 
zoom in.

� Note: You may need 
to deselect the smaller 
circle fi rst, before 
attempting to select the 
larger circle.
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7 Drag the bottom anchor point down to reshape the circle. As you drag, a 
vertical aqua alignment guide should appear when the point is aligned with the 
anchor point at the top of the shape. Drag down until it looks good to you.

8 Double-click the same point to convert it to a corner point (not a curve).

In Adobe XD, you can easily edit existing shapes without having to switch tools 
from the Select tool. Later in this lesson, in the section “Drawing with the Pen 
tool,” you’ll learn about creating and editing paths with the Pen tool and the 
Select tool.

9 Press the Esc key to exit Path Edit mode. You should see the bounding box 
around the shape, not the anchor points on the shape. Drag across both  
shapes to select them. 

10 Click the Subtract button ( ) in the Property Inspector to subtract the smaller 
circle from the shape under it.

Look in the Property Inspector and notice that the Subtract option 
is on. The Boolean operations, such as Subtract, can be toggled off 
later, returning the shapes to two separate shapes.

11 Deselect the Border option in the Property Inspector to remove the border.

�� Tip: You can double-
click the same point 
again to convert it back 
to a corner point.
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12 Click the Fill color box in the Property Inspector to show the Color Picker. 
Select the orange-red color you saved, at the bottom of the panel, to apply it. 

13 Press the Esc key to hide the color picker.

Editing combined shapes
No matter which of the operations you use for combining shapes, you can always 
edit the underlying shapes you started with. Next, you’ll edit shapes from the map 
pin icon you just created.

1 Double-click the newly combined pin icon to enter editing mode for the 
selected shapes. 

2 Click in the smaller circle in the center to select it, if it’s not already selected. 

Notice the blue outline around the entire pin icon. When you double-click 
combined shapes, the outline appears, indicating the combined shapes that you 
are editing. You can see the outline in the following fi gure.

3 Zoom in to the pin icon.

4 Option+Shift-drag (macOS) or Alt+Shift-
drag (Windows) a corner to make the circle 
even smaller. Release the mouse button and 
then the keys.

5 Press the Esc key to stop editing the 
individual shapes, and select the entire 
combined pin icon.

�� Tip: In Lesson 6, 
“Working with Assets 
and CC Libraries,” 
you’ll learn about 
saving colors and 
working smarter.
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6 Choose Object > Path > Convert To Path (macOS) or, on Windows, right-click 
and choose Path > Convert To Path. 

The Convert To Path command is useful if you want to make the path 
combination permanent (you can no longer edit the individual paths) and also 
to be able to edit the anchor points of the combined path.

7 Press Command+S (macOS) or Ctrl+S (Windows) to save the file.

Creating dashed lines
In addition to changing the color and size of a border for content, you can also 
apply a dash. With a path or shape selected, in the Property Inspector you can 
assign specific quantities to the Dash and Gap values. The Dash value is the length 
of each dash segment on the line, and the Gap value is the distance between those 
dash segments.

Aligning content to the pixel grid
When you’re creating vector content in Adobe XD or bringing in vector content 
from other sources, it’s important that the images you export later look sharp. To 
create pixel-accurate designs, you can align artwork to the pixel grid using the 
Align To Pixel Grid option. The pixel grid is an invisible grid of 72 squares per  
inch. Align To Pixel Grid is an object-level property that enables an object to have 
its vertical and horizontal paths aligned to the pixel grid. Next you’ll draw an arrow 
icon and align it to the pixel grid.

1 Choose View > Hide Square Grid (macOS) or, on Windows, right-click the 
artboard and choose Hide Square Grid.

With the square grid off, content you create will no longer be aligned to  
the grid.

2 Press the spacebar and drag to the left to see more of the Icons artboard to the 
right of the other icons. You can also drag on a trackpad with two fingers to pan 
in the document window.



108 LESSON 4 Creating and Editing Graphics

3 Select the Line tool ( ) in the toolbar and 
Shift-drag to make a horizontal line, as you 
see in the fi gure. Release the mouse button 
and then the key.

4 Press Command+3 (macOS) or Ctrl+3 
(Windows) to zoom in to the line. 

5 To deselect the line, press the Esc key. 

Now you’ll draw the arrowhead.

6 With the Line tool selected, starting on the right end of the path you drew, 
Shift-drag up and to the left to make a line that is angled at 45 degrees. 

7 Press Command+D (macOS) or Ctrl+D (Windows) to duplicate the line in 
place. Click the Flip Horizontally button ( ) in the Property Inspector.

8 Select the Select tool and drag the fl ipped 
line straight down. Aqua alignment guides 
will appear to help you align it.

9 Drag across all of the paths and then right- 
click them and choose Group. 

10 In the Property Inspector, change the border 
color to white, change the border size to 4,
and press Return or Enter. Click the Round 
Cap button ( ) to round the ends of 
the line.

� Note: If you fi nd that 
this zoom command 
won’t work, you can 
pinch-zoom on a 
trackpad or select the 
Zoom tool to zoom in.
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11 Shift-drag a corner to make it smaller. Drag until you see a width of around 24 
in the Property Inspector. Release the mouse button and then the key.

Looking in the Property Inspector, you may see that the Width and Height 
values are not whole numbers. Next, you’ll align the artwork in the group to the 
pixel grid, and those values will become whole numbers.

12 Choose Object > Align To Pixel Grid (macOS) or right-click the selected 
artwork and choose Align to Pixel Grid.

Not pixel-grid aligned After aligning to the pixel grid

You probably noticed the subtle shift in the shapes as the paths were aligned 
to the pixel grid. To give you an idea of what just happened, take a look at the 
following figure. On the left is artwork that I didn’t align to the pixel grid before 
I exported it as a PNG; on the right is artwork that is aligned to the pixel grid.

Not aligned before exporting as PNG Aligned before exporting as PNG

You can clearly see the difference on the horizontal and vertical paths.

13 Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the artboards.

14 Click in a blank area of the gray pasteboard to deselect all.

15 Press Command+S (macOS) or Ctrl+S (Windows) to save the file.

� Note: To see the 
change to the Height 
and Width values in the 
Property Inspector, you 
may want to click away 
from the arrow artwork, 
then click to select 
it again.
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Drawing with the Pen tool
Another way to create artwork is to use the Pen tool in Adobe XD. With the Pen 
tool, you can create freeform and more precise artwork, and edit existing shapes. 
In this section, you’ll explore the Pen tool by drawing artwork using straight and 
curved lines, and then you’ll learn how to edit shapes with both the Pen and Select 
tools. First, you’ll open an existing fi le and begin drawing some icons using the 
Pen tool.

1 Choose File > Open From Your 
Computer (macOS), or click the menu 
icon ( ) in the upper-left corner of the 
application window and choose Open 
From Your Computer (Windows). 
Locate the fi le named Drawing.xd, which 
is in the Lessons > Lesson04 folder that 
you copied onto your hard disk. Select 
the fi le and click Open.

Th is document has three icons you’ll 
create. You’ll use templates provided for 
tracing paths, and then you can practice 
on your own.

2 In the Layers panel, double-click the artboard icon ( ) to the left of the 
artboard name “Icon 1” to fi t the artboard in the document window.

Drawing straight lines
You may have some experience with the Pen tool in an application like Illustrator or 
Photoshop. Th e Pen tool in Adobe XD is similar, but in XD creating paths with the 
Pen tool may seem easier and more intuitive. To start drawing with the Pen tool in 
Adobe XD, you’ll create an icon in the shape of a house.

1 Select the Pen tool ( ) in the toolbar. Move the pointer over point 1 and click 
to create an anchor point; then release the mouse button. Make sure you have 
released the mouse button and move the pointer away from the point you just 
created, and you’ll see a line connecting the fi rst point and the pointer, no matter 
where you move the pointer. Th at line gives you a preview of the next line segment 
you will draw. 

�� Tip: You can press 
the P key to select the 
Pen tool.
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Later, as you create curved paths, it will make drawing them easier because you 
can preview what the path will look like. 

2 Move the pointer over point 2, above point 1. 
When the pointer is vertically aligned with the 
fi rst point, the preview line will turn aqua to 
show that it’s aligned. Click point 2 to create 
another anchor point.

You just created a path. A simple path is 
composed of two anchor points and a line 
segment connecting those anchor points. You use the anchor points to control 
the direction, length, and curve of the line segment.

3 Continue clicking points 3, 4, and 5 to create a house shape, releasing the mouse 
button every time you click to create another anchor point.

Th e aqua snap guides are very useful for aligning anchor points you create 
to existing anchor points. Notice that only the last anchor point is fi lled (not 
hollow like the rest of the anchor points), indicating that it is selected.

4 Click the fi rst anchor point you created to 
close the path and stop drawing.

After closing a path, the Select tool ( ) is 
automatically selected. Next, you’ll create a 
path that will be the roof of the house. Th is 
will be an open path, not closed.

5 Select the Pen tool and move the pointer over point 6. Move the pointer around 
and you most likely will see aqua snap guides. Press and hold Command 
(macOS) or Ctrl (Windows) and move the pointer around. You will no longer 
see the aqua alignment guides since dragging with the Command (macOS) or 
Ctrl (Windows) key down temporarily disables the alignment guides. With the 
key still held down, click point 6.

6 With the key held down, click to add a point 
at 7. Release the key and click point 8 to create 
a roof.

Releasing the Command (macOS) or Ctrl 
(Windows) key before adding point 8 allowed 
the alignment guides to work again.

� Note: If the path 
looks curved, you have 
accidentally dragged 
with the Pen tool. Press 
Command+Z (macOS) 
or Ctrl+Z (Windows) to 
undo, and then click 
again without dragging.

�	�	Tip: Instead of 
relying on alignment 
guides to align points 
as you create them, you 
can also press the Shift 
key and click to create 
an anchor point. The 
Shift key constrains the 
angle of the segment 
to a multiple of 45 
degrees.
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7 Press the Esc key to stop drawing the path, which also automatically switches to 
the Select tool.

If you want to practice without the template, try tracing the same shape below 
the template in the area labeled Practice.

Drawing with a square 
artboard grid turned on
Drawing on an artboard with the grid 
turned on means that what you draw 
will snap to the grid lines. This can 
make creating icons or other vector 
objects easier and more precise. To 
avoid snapping to the grid, you can 
press the Command (macOS) or Ctrl 
(Windows) key while dragging the 
mouse and drawing an object.

Drawing curves
Along with creating straight paths with the Pen tool, 
you can also draw curves. As you draw, you create a 
line called a path. A path is made up of one or more 
straight or curved segments. Th e beginning and end 
of each segment are marked by anchor points, which 
work like pins holding a wire in place. 

A path can be closed (for example, a circle) or open, 
with distinct endpoints (for example, a wavy line). 
You change the shape of a path by dragging its anchor 
points or the direction points at the end of direction 
lines (together, direction points and direction lines are 
called direction handles) that appear at anchor points.

Creating curves with the Pen tool can be tricky, but with some practice you’ll soon 
be on your way. Next, you’ll create a curved path. To do this, you’ll drag away from 
a point you create.

1 Press Command+Shift+A (macOS) or Ctrl+Shift+A (Windows) to deselect all.

2 Double-click the artboard icon ( ) to the left of the artboard name “Icon 2” in 
the Layers panel to fi t the artboard in the document window.

�� Tip: You can 
press the spacebar to 
access the Hand tool 
and then drag in the 
document window to 
move to a blank area of 
the artboard.

A B C D

A. Line segment

B. Anchor point

C. Direction line

D. Direction point
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3 Select the Pen tool ( ) in the toolbar. Move 
the pointer over the gray point labeled 1. Press 
and drag to the right, to the blue dot, to create a 
direction line.

The angle and length of direction lines 
determine the shape and size of the curve. As 
you drag away from a point, there are typically two direction handles (except for 
on a starting point), one before the point and one after it. Direction lines move 
together by default and only show when you’re editing paths.

4 Move the pointer over point 2; then press and drag to the right. After you begin 
dragging, press the Shift key to constrain the movement to a multiple of 15 
degrees. When you reach the blue dot, release the mouse button and then the 
key to create direction lines.

Next, you’ll create a corner point with no direction lines, and then go back and 
change it to a smooth point.

5 Move the pointer over point 3. Click and release without dragging to create a 
corner point with no direction lines.

6 Move the pointer over point 4, and press and drag to the right. After you start 
dragging, press the Shift key. When you reach the blue dot, release the mouse 
button and then the key to create a direction line.
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7 Move the pointer over the anchor point at 3. 
When the point turns blue and the pointer 
changes ( ), double-click to convert the point 
to a smooth point with direction handles you 
can edit.

While drawing with the Pen tool in Adobe XD, 
you can always edit the path you are currently 
drawing without switching tools.

8 Move the mouse pointer over point 5 and drag to the right. As you drag, press 
the Shift key. When you reach the blue dot, release the mouse button and then 
the key to create a direction line.

9 Move the mouse pointer over point 6 and drag to the right. As you drag, 
press the Shift key. When you reach the blue dot, release the mouse button and 
then the key to create a direction line.

10 Press the Esc key to stop drawing and automatically switch to the Select tool.

11 Change Border Size to 3 in the Property Inspector. Press Return or Enter.

12 With the Select tool selected, click in a blank area of the gray pasteboard to 
deselect the last path.

If you want to practice without the template, try tracing the same shape below 
the template in the area labeled Practice.

Changing path direction
Th e last icon you will create is a cloud. Th e path will contain an anchor point whose 
direction lines are “split.” Th is means that a curve can be followed by a straight 
path, for instance.

1 Double-click the artboard icon ( ) to the left of the artboard named Icon 3 in 
the Layers panel to fi t the artboard in the document window. To zoom in a bit 
further, press Command and + (macOS) or Ctrl and + (Windows).

2 Select the Pen tool ( ) in the toolbar. Press and drag from point 1 to the left, to 
the blue dot, to create a direction line. Release the mouse button.
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3 Move the mouse pointer over point 2 and drag up to the blue dot to create a 
direction line.

Now you need the next part of the path to switch directions at the anchor point 
and create another curve. You will split the direction lines to convert a smooth 
point to a corner point. Th is involves a keyboard modifi er.

4 Move the pointer over point 3 and drag to the gold dot to create a direction line. 
Release the mouse button.

5 Press the Option (macOS) or Alt (Windows) key and drag the end of the 
direction line to the blue dot. Release the mouse button and then the key.

Th e direction lines are now split, which means you can move them 
independently of each other. Th e trailing direction line controls the curve of the 
path leading up to the anchor point, and the leading direction line controls the 
curve of the path after the anchor point.

6 Move the mouse pointer over point 4 and drag to the right, to the blue dot, to 
continue drawing the path.

When it comes to smooth points (curved), you’ll fi nd that you spend a lot of 
time focusing on the path segment that is created when you place a new anchor 
point. Remember, by default there are two direction lines for a point. Th e 
previous direction line controls the shape of the previous segment.

�	�	Tip: To make the 
handles move together 
again, you can double-
click the corner anchor 
point twice.
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7 Move the pointer over point 5 and drag to the gold dot to create a direction line. 
When the path between points 4 and 5 looks good, release the mouse button.

8 Press the Option (macOS) or Alt (Windows) key and drag the end of the 
direction line to the blue dot. Release the mouse button and then the key.

9 Move the mouse pointer over point 6 and drag down, to the blue dot, to 
continue drawing the path.

10 Move the mouse pointer over point 7 and drag to the left, to the blue dot, to 
continue drawing the path.

11 Move the mouse pointer over point 1 and click to close the cloud path.

If you want to practice without the template, try tracing the same shape below 
the template in the area labeled Practice.

12 Deselect the Border option in the Property Inspector. 

13 Click the Fill color, and in the color picker change the Hex value to an orange-
red (#FF491E). You may need to make sure that Hex is chosen from the menu 
in the lower left corner of the color picker fi rst.

�� Tip: When editing 
the Hex value, you 
can enter Hex values 
using shorthand. You 
can type any Hex value 
to have it repeated 
for all six values. For 
instance, typing a single 
character, such as “f,” 
and pressing Return 
or Enter repeats that 
character for all values 
(#ff ff ff ). Typing two 
characters, such as 
“ab,” repeats in order 
(#ababab). Typing 
three characters, such 
as “123,” repeats each 
character in order 
(#112233).



ADOBE XD CLASSROOM IN A BOOK (2020 RELEASE) 117

Editing artwork with the Pen tool
In Adobe XD, you can edit shapes and paths as you are drawing vector artwork or 
after the artwork is created. In the next few exercises, you’ll focus on editing shapes 
using Path Edit mode.

1 Press Command+Shift+A (macOS) or Ctrl+Shift+A (Windows) to deselect all.

2 Double-click the artboard icon ( ) to the left of the House artboard in the 
Layers panel to fi t the artboard in the document window.

3 With the Select tool ( ) selected, double-
click the top rectangle shape to enter 
Path Edit mode.

4 Move the pointer over the top border of 
the path, as you see in the fi rst part of the 
following fi gure. When the Pen tool icon ( ) appears, click to create a new 
anchor point and release the mouse button.

When in Path Editing mode, you don’t have to switch tools from the Select tool 
to add, delete, and edit points.

5 Drag the anchor point up.

6 Double-click the line above the house shape to enter Path Editing mode. Move 
the pointer over the path, and when you see the Pen tool icon, click to add a 
new anchor point. See the fi rst part of the following fi gure.

7 Drag that same anchor point up a bit. See the second part of the following fi gure. 

8 Press the Esc key to exit Path Edit mode.

At this point, the anchor points aren’t visible, and you cannot edit them; only 
the bounding box of the shape is visible.

9 Drag the path down, above the house icon. See the last part of the following fi gure.

To fi nish the house artwork, you’ll edit the rectangle below the path to look like 
a curving sidewalk.
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10 Double-click the rectangle below the house shape to enter Path Editing mode. 

11 Drag the top two anchor points on the 
selected shapes closer together.

12 Move the pointer over the lower-left anchor 
point and double-click to convert it to a 
smooth point. Th e path at that anchor should 
now be a curve.

13 Click the end of the direction handle pointing down. Press Delete or Backspace 
to remove it. Th e path on that side of the anchor point is now straight.

14 Drag the remaining direction handle up and to 
the right to curve the path.

15 Repeat steps 12–14 on the anchor point in the 
lower-right corner of the same shape.

Copying the cloud icon
Next, you’ll copy the cloud icon you created to the Travel_Design.xd document.

1 Press Command+0 (macOS) or Ctrl+0 (Windows) to zoom out. 

2 With the Select tool selected, right-click the cloud icon and choose Copy.

3 To close and save the Drawing document, choose File > Close (macOS) or click 
the X in the upper-right corner (Windows). 

You should be back in the Travel_Design.xd document.

4 Right-click the Icons artboard and choose Paste to paste the cloud icon. 

5 Drag the icons around on the artboard so they 
are more evenly spaced. Th at will make it a 
little easier to select them later. You may want 
to zoom in to the artboard.

6 Press Command+0 (macOS) or Ctrl+0 
(Windows) to see everything, if necessary. 

� Note: The fi gure 
also shows the anchor 
points closer to the 
house icon above.

� Note: If you started 
with the L4_start.xd 
jumpstart fi le, then 
return to that fi le.
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Working with UI Kits
In Adobe XD you have access to a series of UI (user interface) kits for Apple iOS, 
Microsoft Windows, Google Material (Android), and wireframes. UI kits and 
wireframes can save time when you’re designing for diff erent device interfaces 
and platforms. Th ey are XD fi les that include common design elements such as 
icons, keyboard layouts, navigation bars, inputs, buttons, and more. You can use a 
UI kit as a starting point or copy and paste elements into your own design. 
Th ese resources can help you create a design that matches a specifi c design 
language (like iOS). 

Downloading the UI kit
In this section, you’ll download and unzip a UI kit from the developer.apple.com 
website. You’ll then open an XD fi le from the downloaded fi les and copy a few 
elements into your design.

1 Choose File > Get UI Kits > Apple iOS (macOS) or, on Windows, click the 
menu icon ( ) in the upper-left corner of the application window and choose 
Get UI Kits > Apple iOS.

Th e UI kits listed in the menu you see are links to the websites that they can 
be downloaded from. By choosing Apple iOS, the developer.apple.com website 
is opened in your default browser to a page (developer.apple.com/design/
resources/) where you can download a UI kit specifi cally for Adobe XD.

2 On the web page that opens in your 
default browser, click Download 
For Adobe XD. A DMG fi le is 
downloaded to your computer.

3 Find the DMG fi le that was 
downloaded and double-click it. 
After you accept an agreement, you 
can view the contents in a window. 
Double-click the iOS 13 Adobe XD 
folder to view its contents. 

� Note: If you are on 
Windows or cannot 
access the Adobe 
XD fi le on the Apple 
website, you can open 
the UI_kit_content.xd 
document in XD, 
located in the Lessons > 
Lesson04 folder. You can 
then press Command+A 
(macOS) or Ctrl+A 
(Windows) to select 
all of the content in 
the document, copy 
it, and paste it into the 
Travel_Design.xd fi le 
that is still open.

http://developer.apple.com
http://developer.apple.com
http://developer.apple.com/design/resources/
http://developer.apple.com/design/resources/
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4 Save the UI Elements + Design 
Templates + Guides folder to the 
Lessons folder on your hard drive so 
you can easily fi nd the contents.

5 On macOS, in the same window 
that you double-clicked the iOS 13 
Adobe XD folder, double-click the fi le 
“Download San Francisco.webloc” to 
go to a web page in your browser. On that page, 
click the button to download the SF Pro fonts. 

� Note: If you are on Windows or you don’t install the San Francisco fonts, you may still proceed. 
You will most likely continue to see a missing fonts warning every time you open a fi le that uses the 
content from these UI kits.

6 After the DMG for the fonts is downloaded, 
locate it and double-click it to view the 
contents. Follow the installation instructions 
to install the fonts.

Opening and copying from the UI Kit
With the UI kit downloaded and the San Francisco Pro fonts installed (macOS 
only), now you’ll open one of the downloaded fi les and copy content into your 
Travel_Design.xd document.

� Note: Once again, if you are on Windows or cannot access the Adobe XD fi le on the Apple 
website, you can open the UI_kit_content.xd document in XD, located in the Lessons > Lesson04 
folder. Press Command+A (macOS) or Ctrl+A (Windows) to select all of the content in the document, 
copy it, and paste it into the Travel_Design.xd fi le that is still open.

1 Back in Adobe XD, on macOS, choose File > Open From Your Computer 
(macOS). Navigate to the Lessons > UI Elements + Design Templates + Guides 
folder. Open the UIElements+DesignTemplates+Guides-iPhone.xd fi le in 
that folder. 

On Windows, click the menu icon ( ) in the upper-left corner of the 
application window and choose Open From Your Computer (Windows). Open 
the UI_kit_content.xd document in XD, located in the Lessons > Lesson04 
folder. Press Command+A (macOS) or Ctrl+A (Windows) to select all of the 
content in the document, copy it, and paste it into the Memory artboard of the 
Travel_Design.xd fi le that is still open.

2 Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the content.

� Note: If you’ve 
already closed the 
window, you can open 
developer.apple.com/
fonts/ in your browser.

http://developer.apple.com/fonts/
http://developer.apple.com/fonts/
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Th e content in the UI kit is very well organized, and content is grouped together 
to make selections easier. You will fi nd, however, that it can be challenging to 
select individual objects since there are a lot of groups nested within groups.

3 With the UIElements+DesignTemp-
lates+Guides-iPhone.xd document 
open (macOS), in the Layers panel 
(Command+Y [macOS]), type 
status bars into the search fi eld ( ) at 
the top of the Layers panel to fi lter the 
list of content that appears in the panel 
(circled in the fi gure). Click the name 
“Status Bars” (with the folder icon to 
the left) to select that content in the document. 

4 Press Command+3 (macOS) or Ctrl+3 (Windows) to zoom in to the status bars.

5 Click the X to the right of the search 
fi eld ( ) (circled in the fi gure) at the 
top of the Layers panel to clear the 
fi ltering. You should now see all of the 
content for the UI ELEMENTS - BARS 
artboard listed in the Layers panel.

6 Click the folder icon ( ) (circled in the following fi gure) to the left of the 
Status Bars object in the Layers panel to see the contents of the group. 

You need to select and copy a dark version of the status bar and a light version.

7 Click the “Status Bar” name to the 
right of each folder icon until you see 
the top, black text status bar selected 
(see the fi gure).

8 Click the folder icon for the selected 
Status Bar to show the content (circled 
in the following fi gure). 

9 Click the name “Status Bar” to the left 
of the remaining folder icons until you 
see the top, white text status bar selected (see the fi gure).
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10 Click the folder icon for the selected status bar to show the content. 

11 Press the Command key (macOS) or Ctrl key (Windows), and in the Layers 
panel, click the black status bar and then click the white status bar to select both 
(see the fi gure for which to select). Right-click either of them and choose Copy 
to copy them.

12 Choose File > Close (macOS) to close the fi le and return to the 
Travel_Design.xd document.

13 Back in the Travel_Design.xd document, press Command+V (macOS) or Ctrl+V 
(Windows) to paste the status bars in the center of the document window. Drag 
the pasted content above the Memory artboard for now.

When you drag the pasted content, you may wind up deselecting it instead. In 
Adobe XD, you cannot just drag from within the bounds of the group; you need 
to drag from the content in the group. You may want to zoom in to make it 
easier to drag.

14 Press Command+S (macOS) or Ctrl+S (Windows) to save the fi le. If you plan 
on jumping to the next lesson, you can leave the Travel_Design.xd fi le open. 
Otherwise, for each open document, choose File > Close (macOS) or click the X 
in the upper-right corner (Windows).

� Note: If you started 
with the L4_start.xd 
jumpstart fi le, then 
return to that fi le.
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Review questions
1 What is Path Edit mode?

2 How do you combine several shapes into one?

3 How do you draw straight vertical, horizontal, or diagonal lines using the 
Pen tool ( )?

4 How do you draw a curved path using the Pen tool?

5 How do you convert a smooth point on a curve to a corner point?

6 What is a UI kit?

Review answers
1 Path Edit mode is when shape anchor points are visible but moving the mouse does 

not draw anything. In Path Edit mode, you can edit or delete existing anchor points or 
add new anchor points.

2 To combine several shapes into one, you can select the shapes and then apply one 
of the combine options in the Property Inspector to create new shapes out of the 
overlapping objects. 

3 To draw a straight line, click with the Pen tool ( ) and then move the pointer and 
click again. Th e fi rst click sets the starting anchor point, and the second click sets the 
ending anchor point of the line. To constrain the straight line vertically, horizontally, 
or along a 45 degree diagonal, press the Shift key as you click to create the second 
anchor point with the Pen tool.

4 To draw a curved path with the Pen tool, click to create the starting anchor point and 
release the mouse button. Move the mouse pointer to another part of the artboard, 
drag to set the direction of the curve, and then release the mouse button to end 
the curve.

5 To convert a smooth point on a curve to a corner point (or vice versa), double-click the 
shape or path with the Select tool ( ) to enter Path Edit mode. With the anchor points 
showing on the selected artwork, double-click an anchor point to convert it to the 
opposite. If it’s currently smooth, it will become a corner point and vice versa.

6 A UI kit is a fi le or set of fi les that contains resources, such as user-interface elements 
(buttons, icons, and more), that are specifi c to an operating system. It can help you 
design apps (or websites) that match a design language like iOS.
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INDEX

A
action setting, 233
Adobe After Effects, 331
Adobe Authorized Training Centers, 5
Adobe Create Magazine, 5
Adobe forums, 5
Adobe I/O developer console, 334
Adobe ID, 179, 273, 302, 309
Adobe Illustrator. See Illustrator
Adobe Photoshop. See Photoshop
Adobe XD

described, 8, 27
image formats, 57
installing, 2
mobile app, 273–274
plugins, 332–336
resources, 5, 26
starting work in, 10
system requirements, 2
third-party integration, 338
unit-less nature of, 45
vector graphics and, 91
workspace, 10, 11–12

Adobe XD Learn & Support page, 5, 26
Adobe XD product home page, 5
After Effects projects, 331
Align Center button, 69
Align To Pixel Grid option, 107, 109
aligning

artboards, 42, 145
content to pixel grid, 107–109
guides used for, 92, 111, 145–146
objects to artboard, 139
objects to each other, 142–143

setting up objects for, 139–142
anchor points

creating, 111
editing, 102, 105
paths and, 112

Android
exporting PNG files for, 328
measurement unit for, 309
mobile device previews, 273, 275
resolution settings for, 310

animation
auto-animating content, 248–250
connection setting for, 233

appearance changes
artboard, 40
repeat grid, 210
shape, 96–97

application modes, 11, 12
area text, 78, 80–81, 87
arranging

artboards, 38–39
objects, 127–128

Artboard tool, 34–36, 53
artboards, 11, 12

aligning, 42, 145
appearance changes, 40
arranging, 38–39
browsing on devices, 278
changing multiple, 41
copying and pasting, 39
creating, 34–36
deleting, 35
distributing, 145



ADOBE XD CLASSROOM IN A BOOK (2020 RELEASE) 341

dragging, 38–39
duplicating, 39
editing, 37–39
grids for, 43–48, 53, 112
guides for, 49–50
home screen, 309
linking, 232–234
managing with Layers panel, 51–52, 

53, 130
measurement unit for, 309
navigating, 22–23
orientation options, 37
renaming, 23, 36
reordering, 129, 130, 151
resizing, 37, 53
responsive resize for, 42, 217–218
Retina (HiDPI) sizing for, 32
review questions/answers on, 53
screens represented as, 31
selecting, 37, 38, 40, 41

artwork
adding from Illustrator, 71–72
aligning to pixel grid, 107–109
components created from, 162–163
copying and pasting, 118
editing with Pen tool, 117–118
masking images or, 73–78
zooming in/out of, 17–21, 27

assets
adding to CC Libraries, 179–182
exporting, 320–331
importing, 57–61
linked, 175
managing, 155–178
naming/renaming, 323, 339

Assets panel, 11, 12, 155–178
character styles in, 159–162
components in, 162–178
custom colors in, 155–158
gradient colors viewed in, 193
toggling open/closed, 155
types of assets in, 155, 187

audio recording, 269, 271
auto-animating content, 248–250, 265
auto-correct functionality, 79
Autosave feature, 32
Available Offline option, 282

B
backgrounds

blur effect for, 197–198, 225
color for artboard, 40, 41

blend modes, 202
blur effects

background blur, 197–198
object blur, 198–199

Boolean operations, 104
borders

changing fills and, 96–97
options for working with, 98–99

Bring Forward command, 127
Bring to Front command, 127, 257
Browse artboards option, 278
browsers

previewing prototypes in, 297–298
supported in Adobe XD, 297
viewing design specs in, 308, 309, 

310, 311–316

C
CC Libraries panel, 179–180
character styles, 159–162

CC Library, 182–183
deleting, 162
editing, 161–162, 187
saving, 159–161

circles
creating, 76, 93, 98, 104
duplicating, 100
image fills in, 76

Classroom in a Book training series, 1
closed paths, 112
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cloud documents
described, 32, 285
history states for, 283–284
offline versions of, 281, 282
previewing on devices, 280–282
saving XD documents as, 280
sharing, 290–293
video on working with, 33

code, embed, 301
coediting documents, 293
color picker, 41, 96, 97, 191
color stops, 191, 192, 195, 196
color swatches

deleting, 97, 157
editing, 157–158

colors
background, 40, 41
border, 97, 98
fill, 96, 116
gradient, 194–195
saving, 155–157

Column Width values, 48
combining shapes, 104–106, 123
comment icon, 302, 305
comments, 301–307, 317

adding, 301–302
deleting, 306
guest, 303
pinning, 303–305
working with, 305–307

Comments panel, 302, 303, 304–305
components, 162–178

breaking links to, 178
copying instances of, 173–174
creating, 162–163, 187
defined, 162
editing, 165–166
footer groups as, 167
hover state added to, 242–244
instances of, 164–165, 166, 187
linked, 173–178

local, 173, 178
master, 165, 239–241
multiple states added to, 244–248
replacing, 168–170
ungrouping, 171–172

connecting handles, 234
connections

adding to component masters, 
239–241

copying and pasting, 241
creating, 232–234
editing, 236–239, 265
previewing, 234–235
types of, 265
See also links

content
aligning, 107–109, 139–145
auto-animating, 248–250
grouping, 136–138, 219–220
hiding, 134
Illustrator, 71–72
locking, 133
masking, 73–78
ordering/reordering, 129–130
Photoshop, 65–70
saving as a component, 162–163
selecting, 130–133
Sketch, 70

Content-aware layout 215–217
Convert to Path command, 80, 107
Copy Embed Code command, 300, 301
Copy Link icon, 296, 300
copying and pasting

artboards, 39
component instances, 173–174
connections, 241
embed code, 301
guides, 50
Photoshop files, 65–66
replacement images, 62
selected artwork, 118
text, 81
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from UI kits, 122
Corner Count values, 94, 95
corner points, 105, 113, 123
Corner Radius values, 94, 100, 101
corner radius widgets, 100
Create Link button, 296
Creative Cloud

cloud documents stored in, 32
previewing documents loaded from, 

273, 280–282
saving XD documents to, 280
shared prototypes stored in, 317
working with documents from, 33

Creative Cloud Libraries, 179–186, 187
adding XD assets to, 179–181
character styles used from, 182–183
editing items in, 186
explanation on using, 179
graphics used from, 184–185
Illustrator assets added to, 181–182
selecting multiple objects in, 185

curves, drawing, 112–114, 123
Custom Size icon, 31

D
Dash values, 107
dashed lines, 107
deleting

artboards, 35
character styles, 162
color swatches, 97, 157
comments, 306
downloaded XD files, 279
guides, 50
See also removing

Design mode, 13–15
panels, 14–15
Property Inspector, 13–14
toggling Prototype mode and, 15, 230
tools used in, 13

design review, 289, 295
design specs, 308–316

inspecting, 311–316
sharing, 308–310
viewing, 311–312, 315

designs
finishing, 336–338
previewing, 24
sharing, 25, 27
workflow for UX, 8–9

Desktop Preview, 24, 234, 240
destination setting, 233
development, sharing for, 289, 308–310
Device Preview option, 276
device previews, 273–282

cloud documents for, 280–282
deleting files from, 279
mobile app setup for, 273–274
navigating the mobile app for, 

277–279
USB connection for, 274–279, 285

diamond icon, 168, 248
direction handles, 112
direction lines, 112

creating, 113, 114, 116
splitting, 115

direction points, 112
distances

setting between gaps, 148–149
viewing with temporary guides, 150

distributing
artboards, 145
objects, 143–145

documents
cloud, 32
coediting, 293
creating, 31–32
panning, 21
saving, 33
sharing, 25, 27
switching between, 26
zooming in/out of, 17–21, 27
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blend mode, 202
drop shadow, 200–201
object blur, 198–199

Ellipse tool, 76, 93, 98, 104
ellipses, creating, 93–94
embedding shared prototypes, 301, 317
Export dialog box, 322, 324, 325, 327, 

331
Export For option, 309, 310, 326, 330
exporting assets, 320–331, 339

to After Effects, 331
file formats for, 320, 339
from Illustrator, 72
as JPEG files, 330–331
as PDF files, 321–322
as PNG files, 325–329, 339
as SVG files, 323–325

eye icon, 134
Eyedropper tool, 96, 162

F
feedback icon, 297
file formats

for exporting assets, 320, 339
supported for images, 57, 87

fills
artboard, 40
gradient, 191–196
image, 76–78
shape, 96–97

filtering options
Comments panel, 307
Layers panel, 134–135

Fix Height option, 221
Fix Width option, 221, 222
fixed-position objects, 258–259, 265
flipping

lines, 108
shapes, 103

Flow view, 311, 312
folder icon, 68, 168

downloading
cloud documents, 282
lesson files, 3
UI kits, 119–120

drag triggers, 251–252
dragging

artboards, 38–39
images, 61
text, 81

drawing
curves, 112–114, 123
grid used for, 112
straight lines, 110–112, 123

drop shadow effect, 200–201
duplicating

artboards, 39
lines, 108
shapes, 100
text, 85–86

duration setting, 233, 236, 251

E
easing transitions, 233
editing

artboards, 37–39
artwork, 117–118
CC Library items, 186
character styles, 161–162, 187
color swatches, 157–158
comments, 306
components, 165–166
connections, 236–239
gradient colors, 194–195
group content, 137–138
images in Photoshop, 69–70
masks, 74–76, 77–78
repeat grids, 206–210
shapes, 101–103, 106–107, 117–118

educator resources, 5
effects, 197–202

background blur, 197–198
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Font menu, 82
fonts

fixing missing, 84
formatting, 82, 83–84
message about missing, 90
mobile previews and, 275, 276
used in lesson files, 4

footer components, 167
formatting text, 82–84, 159–162
forums, Adobe, 5
frames

resizing images within, 64
support for inline, 301

full-screen mode, 241, 297

G
Game Bar app, 271–272
gaps

changing in dashed lines, 107
setting between objects, 148–149

gradient editor, 191, 192
gradient slider, 192, 194, 195, 196
gradients, 191–196

applying, 191–194, 225
description of, 191
direction and length adjustments, 

195–196
editing colors of, 194–195
linear and radial, 191

grammar check, 86
graphics

creating and working with, 91
using from CC Libraries, 184–185
See also raster images; vector 

graphics
Grid view, 157, 311
grids, 43–48, 53

drawing with, 112
layout, 43, 47–48
pixel, 107–109
square, 43–46

See also repeat grids
groups, 136–138

creating, 136–137, 219–220
editing content within, 137–138, 151

guest commenting, 303
guides

alignment, 92, 111, 145–146
artboard, 49–50
deleting, 50
locking, 50
temporary, 145–146, 150

Gutter Width values, 48

H
hand pointer, 235
Hand tool, 21, 80, 112
Helvetica Neue font, 4, 79, 82, 161
HEX values, 40, 116, 162, 313
hiding/showing

content on artboards, 134
square grids, 93

HiDPI (Retina) sizing, 32, 326
high-fidelity (hi-fi) designs, 9
Highlight On Canvas command, 84, 157, 

161
history of cloud documents, 283–284
home icon, 297, 298
Home screen, 10, 31, 231, 265, 309
hotspot hints, 277
hover state, 242–244
HSB color values, 41, 128, 192, 194

I
Illustrator

adding assets to CC Libraries from, 
181–182

bringing in content from, 71–72
editing vector graphics in, 186
exporting artwork from, 72

image icon, 68, 130
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resolution settings for, 310
iTunes, 274

J
JPEG format

described, 320
exporting files as, 330–331, 339
importing images in, 57

jumpstart method, 4

L
Layers panel, 11, 12, 129–135

grouping objects using, 137
icons indicating object type in, 130
locking and hiding content in, 

133–134
managing artboards with, 51–52, 53, 

130
opening and working in, 14–15, 

22–23
reordering content in, 129–130
searching and filtering in, 134–135
selecting content using, 130–133
toggling the visibility of, 51

layout grids
applying, 47–48
explained, 43

Learn & Support page, 5, 26
lessons in book

downloading files for, 3
jumpstart method for, 4

libraries. See Creative Cloud Libraries
Libraries panel, 181–182
Line Spacing option, 82
Line tool, 99, 108
linear gradients, 191
lines

creating, 99, 108
curved, 112–114, 123
dashed, 107
drawing, 110–114, 123
duplicating, 108

images, 57–78
adding from Photoshop, 65–69
copying and pasting, 62, 65–66
dragging and dropping, 61
editing in Photoshop, 69–70
filling shapes with, 76–78
formats supported for, 57, 87
importing, 57–61
masking, 73–78
opening from Sketch, 70
ordering in repeat grids, 208
positioning, 63
replacing, 62, 87, 208
sizing/resizing, 57, 58, 64
transforming, 63
using from CC Libraries, 184, 186

importing
drag and drop for, 61
images into Adobe XD, 57–61
multiple assets, 59–60
objects with gradients, 191
text, 81

inline frames, 301
inspecting design specs, 311–316
installing

Adobe XD, 2
plugins, 332–334

instances of components
adding, 164–165
editing, 166, 187

interactions
applying multiple, 252–254
copying and pasting, 241

interactivity
example of prototyping, 9
recording in prototypes, 269–272, 285

Invite To Document icon, 290, 291, 292, 
317

iOS
exporting PNG files for, 329
measurement unit for, 309
mobile device previews, 273, 274
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flipping, 108
straight, 110–112, 123

link icon, 174, 176
linked assets, 175
linked components, 173–178

breaking links to, 178
creating, 173–174
explained, 173
updating, 175–177

Linked Screens icon, 311
links

creating, 232–234
editing, 236–239
managing shared, 316
previewing, 234–235
sharing prototype, 299–300
See also connections

List View button, 164, 174, 260
Live Preview option, 274, 285
local components, 173, 178
Lock Aspect option, 37, 58, 63, 76, 77, 

140, 147
locking

content, 133
guides, 50

low-fidelity wireframes, 9, 27

M
macOS

native zooming, 19
prototype recording, 269–270
system requirements, 2
workspace, 11

Manage Links command, 316
manual constraints, 220–222
margin settings, 48
Mark For Export icon, 308
Mark Version icon, 284
Mask with Shape command, 74
masks, 73–78, 87

editing, 74–76, 77–78
image fill, 76–78
removing from content, 76
shape or path, 73–74

master components
adding connections to, 239–241
editing, 165

Maximize application option, 10
measurement units, 45, 309, 315
menu bar, 11
microphone use, 269, 271
Missing Fonts message, 90
mobile app for Adobe XD, 273–274

navigating, 277–279
setting up, 273–274

mobile device previews, 273–282
cloud documents for, 280–282
deleting files from, 279
mobile app setup for, 273–274
navigating the mobile app for, 

277–279
USB connection for, 274–279, 285

modes
Design mode, 13–15, 230
Prototype mode, 15–16, 230

MP4 file format, 269, 285

N
naming/renaming

artboards, 23, 36
assets, 323, 339
groups, 136

navigating artboards, 22–23
nesting repeat grids, 204
New State option, 244, 245, 246
notifications, 291, 292
notifications icon, 297
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P
padding

setting values for, 215–217
video on working with, 217

panels
overview of main, 14–15
See also Assets panel; Layers panel

panning documents, 19, 21
pasteboard, 11, 131–132, 151
pasting. See copying and pasting
Path Edit mode, 75, 102, 105, 117–118, 

123
paths

components of, 112
converting text to, 80
curved, 112–114, 123
direction changes, 114–116
masking with, 73–74
straight, 110–112

PDF format
described, 320
exporting as, 321–322

Pen tool, 110–118, 123
curves drawn with, 112–114
editing artwork with, 117–118
lines drawn with, 110–112
path direction changes and, 114–116

Photoshop
bringing in content from, 65–69, 87
copying and pasting from, 65–66
editing images in, 58, 69–70, 186
opening files from, 67–69

Pin icon, 259, 303, 304, 305
pinned comments, 303–305, 317
pixel grid, 107–109
pixels, virtual, 43
plugins, 332–336

creating, 334
explained, 332, 339
installing, 332–334
using, 334–336

O
object blur effect, 198–199, 225
objects

aligning to artboard, 139
aligning to each other, 142–143
applying multiple interactions to, 

252–254
arranging, 127–128
distributing, 143–145
fixed-position, 258–259
grouping, 136–138
locking, 133
positioning, 145–150
saving as components, 162–163
setup to align, 139–142

offline cloud documents, 281, 282
on-canvas gradient editor, 192, 195, 196
open paths, 112
ordering/reordering

artboards, 129, 130, 151
images in repeat grids, 208
layer content, 129–130

organizing content, 124–151
aligning objects and, 139–143
arranging objects and, 127–128
distributing objects and, 143–145
groups created for, 136–138
Layers panel for, 129–135
positioning objects and, 145–150
review questions/answers on, 151

orientation, artboard, 37
Outer Stroke button, 98
overlays, 260–264

creating, 262–264
setting up content for, 260–262

overriding properties, 166
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Plugins panel, 11, 12, 332
PNG format

described, 320
exporting as, 325–329, 339

point text, 78–80, 87
Polygon tool, 94, 95
polygons, creating, 94–95
positioning objects, 145–150

aligning with temporary guides, 
145–146

fixed positioning for, 258–259
setting gap distances and, 148–149
viewing distances and, 150

presentation, sharing for, 289
Preview window, 24, 234–235
previewing

connections, 234–235
designs, 24, 27
full-screen, 241
prototypes, 273–282
See also mobile device previews

Previous Artboard action, 239, 240
Property Inspector, 11, 12, 13–14
Prototype mode, 15–16, 230, 314
prototypes, 226–285

auto-animating content in, 248–250
component states in, 242–248
copying/pasting connections in, 241
drag triggers added to, 251–252
editing connections in, 236–239
fixed-position objects in, 258–259
home screen setup for, 231
interactivity in, 9, 232
linking artboards in, 232–234
mode for creating, 15–16, 230
multiple interactions in, 252–254
overlays used in, 260–264
preserving scroll position in, 254–258
previewing on a device, 273–282, 285
purpose of using, 9, 27, 229
recording interactivity in, 269–272, 

285

review questions/answers on, 265, 
285

sharing for review, 294–307
speech playback added to, 264
testing connections in, 234–235
timed transitions in, 264
timed triggers in, 264
voice triggers in, 253, 264

Q
Quality setting, 330, 339

R
radial gradients, 191
radius, corner, 100, 101
raster images

sizing for Adobe XD, 58
using from CC Libraries, 184, 186
See also images

real-time preview, 273
recording prototypes, 269–272, 285

on macOS, 269–270
on Windows, 271–272

Rectangle tool, 73, 92, 99, 101, 127
rectangles

creating, 92, 101
masking with, 73–74
rounding corners of, 99–101

removing
masks from content, 76
text from text area, 81
See also deleting

renaming. See naming/renaming
reordering. See ordering/reordering
repeat grids, 203–214

adding content to, 210–211, 225
creating, 204–206
description of, 203, 225
editing content in, 206–209
finishing touches for, 212–214
modifying appearance of, 210
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documents, 33
scaling images, 58
screens

device size options for, 31
See also artboards

scroll position preservation, 233, 
254–258

content setup for, 254–256
steps in process of, 256–258

searching
in Layers panel, 134–135
in Plugins panel, 332–333

Segoe UI font, 79, 82, 161
Select tool, 13, 34, 38, 40, 41
selecting

artboards using Select tool, 37, 38, 
40, 41

content using Layers panel, 130–133
multiple objects in CC Libraries, 185

Send Backward command, 127, 128
Send To Back command, 127
shadows, drop, 200–201
shapes, 91–109

borders for, 96–98
combining, 104–106, 123
creating, 92–95
duplicating, 100
editing, 101–103, 106–107, 117–118
fills for, 76–78, 96–97
flipping, 103
masking with, 73–74
rotating, 102
rounding corners of, 99–101

Share mode, 289, 294, 295, 301, 309, 
316

shared prototypes, 294–307
commenting on, 301–303, 317
embedding in web pages, 301
file storage for, 317
pinning comments in, 303–305
steps for creating, 294–298
updating, 298–300

nesting, 204
ordering images in, 208
replacing images in, 208, 225
selecting content for, 203–204
setting up text files for, 209
sizing/resizing, 205
ungrouping, 212

replacing
components, 168–170
images, 62, 87, 208

replying to comments, 306
resizing. See responsive resize; sizing/

resizing
resolution settings, 310
resolved comments, 306–307, 317
resources for Adobe XD, 5, 26
responsive resize, 215–222

artboards and, 42, 217–218
description of, 215
finishing designs after, 222–224
getting started with, 217–218
grouping content for, 219–220
manual constraints for, 220–222
padding values for, 215–217

Retina (HiDPI) sizing, 32, 326
review, sharing for, 289, 294–310
rotating

artwork, 75
devices, 277
shapes, 102
text, 79

Round Cap button, 99, 108
rounded-corner rectangles, 99–101

S
San Francisco fonts, 4, 120
saving

character styles, 159–161
colors, 155–157
components, 162–163

repeat grids (continued)
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working with comments in, 305–307
sharing, 286–317

cloud documents, 290–293
design specs, 308–310
documents, 25, 27
managing links for, 316
overview on methods of, 289
prototypes for review, 294–307
review questions/answers on, 317

sizing/resizing
artboards, 37, 53, 217–218
images, 57, 58, 64
repeat grids, 205
See also responsive resize

Sketch files, 70
smooth points, 113, 114, 115, 123
snapping

avoiding, 94, 112
disabling, 63, 87

speech playback, 264
spelling check, 86
square grids

explained, 43
hiding/showing, 93
shape creation and, 101
snapping function and, 94, 103, 112
turning off, 94
working with, 43–46

stacking order, 127, 151
Star Ratio option, 94, 95
stars, creating, 95
states added to components

hover state, 242–244
multiple states, 244–248
principles for editing, 248

straight lines, 110–112, 123
styles, text/character, 82–84, 159–162
Subtract option, 105
SVG format

described, 320
exporting as, 323–325

swapping components, 168–170
swatches. See color swatches
Swatches button, 186
symbols. See components
system requirements, 2, 273

T
tap triggers, 233, 238, 250, 253, 256
temporary guides

aligning with, 145–146
viewing distances with, 150

text, 78–86
area, 78, 80–81, 87
converting, 80
duplicating, 85–86
importing, 81
point, 78–80, 87
removing, 81
rotating, 79
spelling/grammar check, 86
styling, 82–84, 159–162

text files, for repeat grids, 209
Text tool, 79, 80, 83, 159, 166
third-party integration, 338
timed transitions, 264
timed triggers, 264
toolbar, 11, 12
tools

Design mode, 13
Prototype mode, 16

transforming images, 63
transitions, 233, 264
triggers, 233, 265

drag, 251–252
tap, 233, 238, 250, 253, 256
timed, 264
voice, 253, 264
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U
UI Faces plugin, 333, 334, 335
UI kits, 119–122, 123

copying/pasting from, 122
downloading, 119–120
opening content in, 120–122

undo command, 111, 166, 221
Ungroup Grid button, 212, 335
Ungroup Mask command, 76
ungrouping

components, 171–172
grouped icons, 147
repeat grids, 212

units of measurement, 45, 309, 315
Unlink Component option, 204
updating

cloud documents, 282
linked components, 175–177
shared prototypes, 298–300

USB-connected previews, 273, 274–279, 
285

user experience (UX) design workflow, 
8–9

user testing, sharing for, 289

V
vector graphics

Adobe XD and, 91
Illustrator content as, 71
using from CC Libraries, 184, 186
working with shapes as, 91–109

versions of cloud documents, 283–284
video recording prototypes, 269–272
videos

on cloud documents, 33
on coediting documents, 293
on exporting Illustrator artwork, 72
on padding, 217
on speech playback, 264
on timed transitions, 264
on timed triggers, 264

on voice triggers, 264
view commands, 17–18
View Specs button, 312
viewing

design specs, 311–312, 315
distances, 150

virtual pixels, 43
voice triggers, 253, 264

W
Web Edition of book, 3
web pages

embedding shared prototypes in, 301, 
317

measurement units for, 309
resolution settings for, 310

widgets, corner, 100
Windows

native zooming, 19
prototype recording, 271–272
system requirements, 2
workspace, 12

wireframes, low-fidelity, 9, 27
workflow, UX design, 8–9
workspaces, 10

macOS, 11
Windows, 12

X
XD program. See Adobe XD
XDX file format, 332

Z
Zeplin tool, 338
Zoom tool, 19–21, 108
zooming in/out, 17–21, 27
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